aboutsummaryrefslogtreecommitdiffstats
path: root/community/connman-resolvconf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/connman-resolvconf/APKBUILD')
-rw-r--r--community/connman-resolvconf/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/connman-resolvconf/APKBUILD b/community/connman-resolvconf/APKBUILD
new file mode 100644
index 00000000000..bd581ea5b07
--- /dev/null
+++ b/community/connman-resolvconf/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=connman-resolvconf
+pkgver=0.2.0
+pkgrel=2
+pkgdesc="ConnMan integration with resolvconf(8)"
+url="https://github.com/jirutka/connman-resolvconf"
+arch="aarch64 armhf armv7 ppc64le x86 x86_64" # blocked by rust/cargo
+license="MIT"
+depends="
+ cmd:resolvconf
+ connman
+ dbus
+ "
+makedepends="cargo dbus-dev cargo-auditable"
+subpackages="$pkgname-openrc"
+source="https://github.com/jirutka/connman-resolvconf/archive/v$pkgver/connman-resolvconf-$pkgver.tar.gz"
+options="!check" # no tests provided
+
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
+
+build() {
+ cargo auditable build --frozen --release
+}
+
+package() {
+ install -D -m755 target/release/connman-resolvconfd -t "$pkgdir"/usr/sbin/
+ install -D -m755 contrib/openrc/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -D -m644 contrib/openrc/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="
+66addbf52084ca2c46a13e57d10d9acd2a10e39e166bc910d8910cc44ddaf734aff2f8cbf393eb7e4e26c9733364ced1199384b69a69b79e3491e72f4f327ccc connman-resolvconf-0.2.0.tar.gz
+"