aboutsummaryrefslogtreecommitdiffstats
path: root/community/consul-template/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/consul-template/APKBUILD')
-rw-r--r--community/consul-template/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/consul-template/APKBUILD b/community/consul-template/APKBUILD
index 16a8338a4e0..aef78d92c1e 100644
--- a/community/consul-template/APKBUILD
+++ b/community/consul-template/APKBUILD
@@ -1,23 +1,31 @@
# Contributor: Gennady Feldman <gena01@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=consul-template
-pkgver=0.29.0
-pkgrel=1
+pkgver=0.36.0
+pkgrel=2
pkgdesc="Generic template rendering and notifications with Consul"
url="https://www.consul.io/"
arch="all"
license="MPL-2.0"
makedepends="go"
-options="!check"
+options="!check chmod-clean net"
subpackages="$pkgname-openrc"
source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/consul-template/archive/refs/tags/v$pkgver.tar.gz
consul-template.hcl
consul-template.initd
"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+# secfixes:
+# 0.29.2-r0:
+# - CVE-2022-38149
+
build() {
- CGO_ENABLED="0" go build -a -v -o bin/$pkgname \
- -ldflags "-s -w
+ go build -a -v -o bin/$pkgname \
+ -ldflags "
-X github.com/hashicorp/$pkgname/version.Name=$pkgname \
-X github.com/hashicorp/$pkgname/version.GitCommit=$pkgver"
}
@@ -29,13 +37,8 @@ package() {
install -Dm755 "$srcdir"/consul-template.initd "$pkgdir"/etc/init.d/"$pkgname"
}
-cleanup_srcdir() {
- [ -d src ] && chmod -R +w src
- default_cleanup_srcdir
-}
-
sha512sums="
-e562d89c753ca2bbd14ae57e084e7e2b0aac28c92c210357e22d32d5c3c138054a46f5fb8883a44f64bdd8e9654f457230cef3b24513fa7eeaefd177fd8004c7 consul-template-0.29.0.tar.gz
+6d821fec00f7ac46eb952895573bbc8b5412eac36ab7e71785c7f0179e5ff4817ef1732a36d4396f4953a3d1332f81e3756b83e4706fe6713b6840f2e9e22e99 consul-template-0.36.0.tar.gz
bfb5c7eed53cfe45d9e03eeb68eb454d2f47a47402a99b008895c261389160d611ab72903cdfb98e99a88749e0fd00733a9fad70b9def9af35657cba12987ea9 consul-template.hcl
-15a5edc20c3239743c58ca485dc51e2851a072b9b2424980854aa4842ac423d65041584a6572c81eab328ed68a41094b7a6771dd94c33155db741b27259f5ff6 consul-template.initd
+d8465a24ca721d57677a25f3f988f37f78147aae83d00c9055663cbd76734a490233691827561138bd02f10067c94c309fb8a0c3473c3b361edb4faa7005fbcb consul-template.initd
"