aboutsummaryrefslogtreecommitdiffstats
path: root/community/containerd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/containerd/APKBUILD')
-rw-r--r--community/containerd/APKBUILD39
1 files changed, 30 insertions, 9 deletions
diff --git a/community/containerd/APKBUILD b/community/containerd/APKBUILD
index e056d9d9dc8..22b41d1b830 100644
--- a/community/containerd/APKBUILD
+++ b/community/containerd/APKBUILD
@@ -4,16 +4,17 @@
pkgname=containerd
# NOTE: containerd's Makefile tries to get REVISION from git, but we're building from a tarball.
-_commit=10c12954828e7c7c9b6e0ea9b0c02b01407d3ae1
-pkgver=1.6.6
+_commit=dcf2847247e18caba8dce86522029642f60fe96b
+pkgver=1.7.14
pkgrel=0
pkgdesc="An open and reliable container runtime"
url="https://containerd.io/"
arch="all"
license="Apache-2.0"
depends="runc"
-makedepends="btrfs-progs-dev go go-md2man libseccomp-dev"
+makedepends="btrfs-progs-dev go go-md2man libseccomp-dev log_proxy"
subpackages="
+ $pkgname-ctr
$pkgname-doc
$pkgname-stress
$pkgname-openrc
@@ -25,6 +26,11 @@ source="containerd-$pkgver.tar.gz::https://github.com/containerd/containerd/arch
options="net"
# secfixes:
+# 1.6.18-r0:
+# - CVE-2023-25153
+# - CVE-2023-25173
+# 1.6.12-r0:
+# - CVE-2022-23471
# 1.6.6-r0:
# - CVE-2022-31030
# 1.6.2-r0:
@@ -60,12 +66,14 @@ options="net"
# - CVE-2019-9946
export GOFLAGS="$GOFLAGS -modcacherw -mod=readonly"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
export GO111MODULE=on
- make VERSION="v$pkgver" REVISION="$_commit" BUILDMODE=pie \
- EXTRA_LDFLAGS="-s -w"
+ make SHIM_CGO_ENABLED=1 VERSION="v$pkgver" REVISION="$_commit" BUILDMODE=pie
make man
}
@@ -75,7 +83,9 @@ check() {
package() {
install -d "$pkgdir"/usr/bin/
- install -Dsm755 "$builddir"/bin/* "$pkgdir"/usr/bin/
+ install -Dsm755 ./bin/* "$pkgdir"/usr/bin/
+ # useless binary only to make manpages
+ rm "$pkgdir"/usr/bin/gen-manpages
install -Dm755 "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname
@@ -90,13 +100,24 @@ package() {
"$pkgdir"/usr/bin/containerd config default | sed "s|/opt/cni/bin|/usr/libexec/cni|g" > "$pkgdir"/etc/containerd/config.toml
}
+openrc() {
+ default_openrc
+ depends="log_proxy"
+ install_if="openrc $pkgname=$pkgver-r$pkgrel"
+}
+
+ctr() {
+ pkgdesc="unsupported debug/admin client for containerd"
+ amove usr/bin/ctr
+}
+
stress() {
pkgdesc="containerd-stress utility"
amove usr/bin/containerd-stress
}
sha512sums="
-f16f23384dbaa67075f2d35b7fc752938dd15601bbe3a919bc8eaa53fa1b2dea2e2d7f613a0f2f492910213dc2f7e96f0a1d38dde35bfb6d15f18167313f9817 containerd-1.6.6.tar.gz
-21a9888b684913138ec4a342b0b69e40e9c773ecd329c4e2401a807365586468cb19035583a4fc8b0f86138f5ee4c7fb911c75495263e4b43d2886ea11e0e271 containerd.confd
-2818cb9e062a6b75c5e2ad6a076eb26edc9fd9b70356b37f9306d082dc360a2d7bd802531afd8e73998cc0fdaa6ad34cd7a0a1d67bd98ee1bb7f30bab16d6084 containerd.initd
+c80ad36027407b2e06fdff76280750f84de8d7300ef8be275976766f2a0a04dec1f0f850c8efcceaa7f6163f43922b427d7ae1fcdeabfaf531f487c25c461dc8 containerd-1.7.14.tar.gz
+5fb37b88554422738cc75b944b75836c123d87d418a16c6a25b9d49da023bd0e654d1aa694e60026de42c055ccf7469f5b4778a4876e94720ec2f40d618db580 containerd.confd
+8315a8d58b4ba7e19ebed2cd82c7b5eaab45da630f9818a9e6cc8f3c8e88f159432474299798f79e6e465e843c91c0f50df04030083c8913c385ea1d73e81e6a containerd.initd
"