aboutsummaryrefslogtreecommitdiffstats
path: root/community/containers-common/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/containers-common/APKBUILD')
-rw-r--r--community/containers-common/APKBUILD48
1 files changed, 24 insertions, 24 deletions
diff --git a/community/containers-common/APKBUILD b/community/containers-common/APKBUILD
index 676feadb8d2..f7d09c8fb67 100644
--- a/community/containers-common/APKBUILD
+++ b/community/containers-common/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=containers-common
-pkgver=0.36.0
+pkgver=0.57.0
pkgrel=0
pkgdesc="Configuration files for container tools"
url="https://github.com/containers/common"
@@ -10,29 +10,29 @@ arch="noarch"
options="!check" # no test suite
makedepends="go-md2man"
subpackages="$pkgname-doc"
-# Pick the newest versions of common/storage/image vendored
-# in podman, skopeo and buildah (but there is no strict rule).
-# Check them with the list_vendors function. Ideally, they
-# should be the same.
+# Pick the exact versions of common/storage/image vendored in podman.
+# Ideally, they should be the same in skopeo and buildah.
+# Check them with the list_vendors function.
_common_ver=$pkgver
-_storage_ver=1.29.0
-_image_ver=5.11.0
-_podman_ver=3.1.1
-_skopeo_ver=1.2.3
-_buildah_ver=1.20.1
+_storage_ver=1.51.0
+_image_ver=5.29.0
+_podman_ver=4.8.0
+_skopeo_ver=1.14.0
+_buildah_ver=1.33.2
+_shortnames_ver=2023.02.20
source="https://github.com/containers/common/archive/v$_common_ver/common-$_common_ver.tar.gz
https://github.com/containers/storage/archive/v$_storage_ver/storage-$_storage_ver.tar.gz
https://github.com/containers/image/archive/v$_image_ver/image-$_image_ver.tar.gz
https://github.com/containers/podman/archive/v$_podman_ver/podman-$_podman_ver.tar.gz
https://github.com/containers/skopeo/archive/v$_skopeo_ver/skopeo-$_skopeo_ver.tar.gz
https://github.com/containers/buildah/archive/v$_buildah_ver/buildah-$_buildah_ver.tar.gz
+ https://github.com/containers/shortnames/archive/v$_shortnames_ver/shortnames-$_shortnames_ver.tar.gz
"
list_vendors() {
unpack
- for tool in podman-$_podman_ver skopeo-$_skopeo_ver buildah-$_buildah_ver
- do
+ for tool in podman-$_podman_ver skopeo-$_skopeo_ver buildah-$_buildah_ver; do
cd "$srcdir"/$tool
msg $tool
grep github.com/containers/common go.mod
@@ -63,9 +63,6 @@ build() {
cd "$srcdir"/image-$_image_ver
make docs
-
- cd "$srcdir"/podman-$_podman_ver
- make docs
}
package() {
@@ -89,12 +86,12 @@ package() {
install -Dm644 registries.conf "$pkgdir"/etc/containers/registries.conf
make install DESTDIR="$pkgdir"
- cd "$srcdir"/podman-$_podman_ver
- install -Dm644 pkg/hooks/docs/oci-hooks.5 "pkgdir"/usr/share/man/man5/oci-hooks.5
-
cd "$srcdir"/skopeo-$_skopeo_ver
install -Dm644 default-policy.json "$pkgdir"/etc/containers/policy.json
install -Dm644 default.yaml "$pkgdir"/etc/containers/registries.d/default.yaml
+
+ cd "$srcdir"/shortnames-$_shortnames_ver
+ install -Dm644 shortnames.conf "$pkgdir"/etc/containers/registries.conf.d/00-shortnames.conf
}
doc() {
@@ -102,9 +99,12 @@ doc() {
pkgdesc="Man pages for container tools"
}
-sha512sums="bf9929cc22138733fa6227de840e0528d56b8809cff18a9a6c106e621e63bf89eeb7506572c49f29503ab86ba899f2bfe8f157ddf38705a9887166efd3a56b3b common-0.36.0.tar.gz
-dfb22b8d14244f04fce453664efc146a6f957ac0223888dc74ed0e40e15089615bd44c30577c1ed7b9984e3778af53184f477c9df4a5d21d811c1b4557338589 storage-1.29.0.tar.gz
-ec91d3483f6c41e310fb4ea51593850da19e09a08b784784bfe4875ced4ea1088bab28418187fe57ac316a0d8d6293a438cd398d75320ad5c64caa5744f9dda8 image-5.11.0.tar.gz
-2348b06c81352a86f51ac9c5ab7fe21e1ce577dfd0164c043baa2fb8a89928e3fdcc13fa75dd731572175ba4232fa27a2e31a3715a2b1596a38a64de919da1b7 podman-3.1.1.tar.gz
-06e3ddc17f45a7b145c44c58d67894d3fff809cd1521753027c703c44425241d4580096fd44d9156eae70336544110e2af95ab6f9d22deff88903c6e77bbe4d8 skopeo-1.2.3.tar.gz
-22495d9f0da1d6061ddb41e4cecfdb2108c152262798d6c959fc524870160f15ee486bcc37e262e571c64dc732e852f05e6c4b9331bbdef4150bd56997fefa83 buildah-1.20.1.tar.gz"
+sha512sums="
+b993821040788085ff44e48023a64cea4e3e7e50731c359087bd287168e6849a543d930acbdaff2437fc7951acc46f7183f337dd977215eca814332e6869d1e3 common-0.57.0.tar.gz
+89916b49438bce8bb774b4aa799676d4b3a946a0b5207a1b5241b1a3ac0875b06b3cd8e81d7e23332ceae6010b693516fc31d8c7f75a37e7ad3056a83c75b6c1 storage-1.51.0.tar.gz
+5e670f85fe0b43769667f1a3e710434ab65c4ec2d8c60b0cad4b0ed41c35f84677528f9dfecb0b946de556ebbdd56f4949760432ec49b1b3c691120a323af869 image-5.29.0.tar.gz
+2178a9c8428a0cf2c402e0f299efe2ad9a797143e641a92438112694a4acbdfb69ba8c104c87f4763d001f17cedb709eef24d86460d095a61a64d29a168a2051 podman-4.8.0.tar.gz
+59d329036a97cbeca4de20b15d9dd8adacd5201834b26ae5e5c88b05594b2a7101c22da91f22c35c07a98e41afa28f2c7103e660b3847c7f8c9691f27f4c4146 skopeo-1.14.0.tar.gz
+574c1a249d93edd5f89e106cd192da94235edcff097d9bce841e3b3b3a9588029deddaceb301505114b994e854016c72090cc0016a00ef027b25f3672a3fab32 buildah-1.33.2.tar.gz
+856dbbeb2acda276e9605bd1ecec0f8d65952c597ee2af61dd8909d7d3c04e5ef06c40b69ec4a98f79e623c536850f614c1b0af3a19637e300e7d3a285933193 shortnames-2023.02.20.tar.gz
+"