aboutsummaryrefslogtreecommitdiffstats
path: root/community/containers-common/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/containers-common/APKBUILD')
-rw-r--r--community/containers-common/APKBUILD46
1 files changed, 22 insertions, 24 deletions
diff --git a/community/containers-common/APKBUILD b/community/containers-common/APKBUILD
index 9ed17052160..f7d09c8fb67 100644
--- a/community/containers-common/APKBUILD
+++ b/community/containers-common/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=containers-common
-pkgver=0.38.5
+pkgver=0.57.0
pkgrel=0
pkgdesc="Configuration files for container tools"
url="https://github.com/containers/common"
@@ -10,29 +10,29 @@ arch="noarch"
options="!check" # no test suite
makedepends="go-md2man"
subpackages="$pkgname-doc"
-# Pick the newest versions of common/storage/image vendored
-# in podman, skopeo and buildah (but there is no strict rule).
-# Check them with the list_vendors function. Ideally, they
-# should be the same.
+# Pick the exact versions of common/storage/image vendored in podman.
+# Ideally, they should be the same in skopeo and buildah.
+# Check them with the list_vendors function.
_common_ver=$pkgver
-_storage_ver=1.31.3
-_image_ver=5.12.0
-_podman_ver=3.2.0
-_skopeo_ver=1.3.0
-_buildah_ver=1.21.1
+_storage_ver=1.51.0
+_image_ver=5.29.0
+_podman_ver=4.8.0
+_skopeo_ver=1.14.0
+_buildah_ver=1.33.2
+_shortnames_ver=2023.02.20
source="https://github.com/containers/common/archive/v$_common_ver/common-$_common_ver.tar.gz
https://github.com/containers/storage/archive/v$_storage_ver/storage-$_storage_ver.tar.gz
https://github.com/containers/image/archive/v$_image_ver/image-$_image_ver.tar.gz
https://github.com/containers/podman/archive/v$_podman_ver/podman-$_podman_ver.tar.gz
https://github.com/containers/skopeo/archive/v$_skopeo_ver/skopeo-$_skopeo_ver.tar.gz
https://github.com/containers/buildah/archive/v$_buildah_ver/buildah-$_buildah_ver.tar.gz
+ https://github.com/containers/shortnames/archive/v$_shortnames_ver/shortnames-$_shortnames_ver.tar.gz
"
list_vendors() {
unpack
- for tool in podman-$_podman_ver skopeo-$_skopeo_ver buildah-$_buildah_ver
- do
+ for tool in podman-$_podman_ver skopeo-$_skopeo_ver buildah-$_buildah_ver; do
cd "$srcdir"/$tool
msg $tool
grep github.com/containers/common go.mod
@@ -63,9 +63,6 @@ build() {
cd "$srcdir"/image-$_image_ver
make docs
-
- cd "$srcdir"/podman-$_podman_ver
- go-md2man -in pkg/hooks/docs/oci-hooks.5.md -out pkg/hooks/docs/oci-hooks.5
}
package() {
@@ -89,12 +86,12 @@ package() {
install -Dm644 registries.conf "$pkgdir"/etc/containers/registries.conf
make install DESTDIR="$pkgdir"
- cd "$srcdir"/podman-$_podman_ver
- install -Dm644 pkg/hooks/docs/oci-hooks.5 "pkgdir"/usr/share/man/man5/oci-hooks.5
-
cd "$srcdir"/skopeo-$_skopeo_ver
install -Dm644 default-policy.json "$pkgdir"/etc/containers/policy.json
install -Dm644 default.yaml "$pkgdir"/etc/containers/registries.d/default.yaml
+
+ cd "$srcdir"/shortnames-$_shortnames_ver
+ install -Dm644 shortnames.conf "$pkgdir"/etc/containers/registries.conf.d/00-shortnames.conf
}
doc() {
@@ -103,10 +100,11 @@ doc() {
}
sha512sums="
-d25c06e002cf840e4486ac8b84e9037777b5edd5d40a605c5f1c8a7283fc6f2920588fee851d408e4d275a3673e4fdfef30f9229c01db593f293411a58e8b577 common-0.38.5.tar.gz
-79e5dd7373d3c018f8d635b5f5f4f31f1f967d80854552c97cdf874d0caf3dcf7c1323880abefea2ec079383f97c85d05561bf1d8077fc219b29544612f1346b storage-1.31.3.tar.gz
-c690b1c4fd67754c41cc590279382a8f4228e3160db5ba482455b4c0ef4b6bd40ea92d0ca7662b2cc1504d82afdb33bdce8d60552ba3e216102ed34e1418d8c0 image-5.12.0.tar.gz
-7db6145e5b303b29b600e9393d0d872931bbe39c385c4e9904b59b1b9a9b87f0191374cc8a13e021d4446c31e461f7be3765c2d18bcb8461df732c89fc848c96 podman-3.2.0.tar.gz
-5b6e96fff4670d8dcbc787cd5a568112337a111e7c44111226fa5684edffa880a1d632660238c55b6193ba26496697dd7e38d7d015cdfd61ce5efb119f0e12eb skopeo-1.3.0.tar.gz
-8fb30ed0948f898aef9a32c34d4b2a2e04a376257a73184ec01b67c770be1c3c87e46987ad001ececf2235cb5e17f9d0ff9e9f34be61ddd0935859c4e5b37d1f buildah-1.21.1.tar.gz
+b993821040788085ff44e48023a64cea4e3e7e50731c359087bd287168e6849a543d930acbdaff2437fc7951acc46f7183f337dd977215eca814332e6869d1e3 common-0.57.0.tar.gz
+89916b49438bce8bb774b4aa799676d4b3a946a0b5207a1b5241b1a3ac0875b06b3cd8e81d7e23332ceae6010b693516fc31d8c7f75a37e7ad3056a83c75b6c1 storage-1.51.0.tar.gz
+5e670f85fe0b43769667f1a3e710434ab65c4ec2d8c60b0cad4b0ed41c35f84677528f9dfecb0b946de556ebbdd56f4949760432ec49b1b3c691120a323af869 image-5.29.0.tar.gz
+2178a9c8428a0cf2c402e0f299efe2ad9a797143e641a92438112694a4acbdfb69ba8c104c87f4763d001f17cedb709eef24d86460d095a61a64d29a168a2051 podman-4.8.0.tar.gz
+59d329036a97cbeca4de20b15d9dd8adacd5201834b26ae5e5c88b05594b2a7101c22da91f22c35c07a98e41afa28f2c7103e660b3847c7f8c9691f27f4c4146 skopeo-1.14.0.tar.gz
+574c1a249d93edd5f89e106cd192da94235edcff097d9bce841e3b3b3a9588029deddaceb301505114b994e854016c72090cc0016a00ef027b25f3672a3fab32 buildah-1.33.2.tar.gz
+856dbbeb2acda276e9605bd1ecec0f8d65952c597ee2af61dd8909d7d3c04e5ef06c40b69ec4a98f79e623c536850f614c1b0af3a19637e300e7d3a285933193 shortnames-2023.02.20.tar.gz
"