aboutsummaryrefslogtreecommitdiffstats
path: root/community/containers-common/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/containers-common/APKBUILD')
-rw-r--r--community/containers-common/APKBUILD46
1 files changed, 22 insertions, 24 deletions
diff --git a/community/containers-common/APKBUILD b/community/containers-common/APKBUILD
index 062607de13a..f7d09c8fb67 100644
--- a/community/containers-common/APKBUILD
+++ b/community/containers-common/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=containers-common
-pkgver=0.48.0
+pkgver=0.57.0
pkgrel=0
pkgdesc="Configuration files for container tools"
url="https://github.com/containers/common"
@@ -10,29 +10,29 @@ arch="noarch"
options="!check" # no test suite
makedepends="go-md2man"
subpackages="$pkgname-doc"
-# Pick the newest versions of common/storage/image vendored
-# in podman, skopeo and buildah (but there is no strict rule).
-# Check them with the list_vendors function. Ideally, they
-# should be the same.
+# Pick the exact versions of common/storage/image vendored in podman.
+# Ideally, they should be the same in skopeo and buildah.
+# Check them with the list_vendors function.
_common_ver=$pkgver
-_storage_ver=1.40.2
-_image_ver=5.21.1
-_podman_ver=4.1.0
-_skopeo_ver=1.7.0
-_buildah_ver=1.26.1
+_storage_ver=1.51.0
+_image_ver=5.29.0
+_podman_ver=4.8.0
+_skopeo_ver=1.14.0
+_buildah_ver=1.33.2
+_shortnames_ver=2023.02.20
source="https://github.com/containers/common/archive/v$_common_ver/common-$_common_ver.tar.gz
https://github.com/containers/storage/archive/v$_storage_ver/storage-$_storage_ver.tar.gz
https://github.com/containers/image/archive/v$_image_ver/image-$_image_ver.tar.gz
https://github.com/containers/podman/archive/v$_podman_ver/podman-$_podman_ver.tar.gz
https://github.com/containers/skopeo/archive/v$_skopeo_ver/skopeo-$_skopeo_ver.tar.gz
https://github.com/containers/buildah/archive/v$_buildah_ver/buildah-$_buildah_ver.tar.gz
+ https://github.com/containers/shortnames/archive/v$_shortnames_ver/shortnames-$_shortnames_ver.tar.gz
"
list_vendors() {
unpack
- for tool in podman-$_podman_ver skopeo-$_skopeo_ver buildah-$_buildah_ver
- do
+ for tool in podman-$_podman_ver skopeo-$_skopeo_ver buildah-$_buildah_ver; do
cd "$srcdir"/$tool
msg $tool
grep github.com/containers/common go.mod
@@ -63,9 +63,6 @@ build() {
cd "$srcdir"/image-$_image_ver
make docs
-
- cd "$srcdir"/podman-$_podman_ver
- go-md2man -in pkg/hooks/docs/oci-hooks.5.md -out pkg/hooks/docs/oci-hooks.5
}
package() {
@@ -89,12 +86,12 @@ package() {
install -Dm644 registries.conf "$pkgdir"/etc/containers/registries.conf
make install DESTDIR="$pkgdir"
- cd "$srcdir"/podman-$_podman_ver
- install -Dm644 pkg/hooks/docs/oci-hooks.5 "pkgdir"/usr/share/man/man5/oci-hooks.5
-
cd "$srcdir"/skopeo-$_skopeo_ver
install -Dm644 default-policy.json "$pkgdir"/etc/containers/policy.json
install -Dm644 default.yaml "$pkgdir"/etc/containers/registries.d/default.yaml
+
+ cd "$srcdir"/shortnames-$_shortnames_ver
+ install -Dm644 shortnames.conf "$pkgdir"/etc/containers/registries.conf.d/00-shortnames.conf
}
doc() {
@@ -103,10 +100,11 @@ doc() {
}
sha512sums="
-82d823899a39e6d08de5e8880edc5af41165188d9a54346b0ddb0a27e3697af3a4b33e9905fa87ae9e545a0bb5f68fea9a88ae2268e252f0fe20852a41e80057 common-0.48.0.tar.gz
-f4ff23e26d9103debc1709cbbbc6e715d2b9378a3bd7c2e72393841b2eb499ffce525526aa53bd1f7985cda87962a98f1d0b4601610f7cee8c9c879957575ad2 storage-1.40.2.tar.gz
-d4d6d6dc9e1359dbf23165d0f636eeb89246efa89c2b38cb5760e3cec6439234fb708a72e8ec5d07fe8bf9a12ef81b9040c03d70cacff2764c926a3f77d133b0 image-5.21.1.tar.gz
-4d5f240423f21b1224ce44853a2265359dacee0d921f0ea53a7fca34f9076ebfaa49f4327a59ac51f5bf5b9dafb47dda3a9bb8e609237cc69f833b42b95bcd0a podman-4.1.0.tar.gz
-7d17f98e86677150fb2ddba9edae18d8b1ac8f06fba575268e6ba54c60f7b371b5e5a9eab1a4fe19da6c7e85eb79c1eef169ad2a39eff979130ee8d141bd8d6b skopeo-1.7.0.tar.gz
-07225ebb23e5a815be1ef8acb5d15ef9fb8c6e9324fa9b65ec024f7b6bbe892721f9feaac2911d1b466c2cf336bd0c68e3d1b4df953f13a3390da84a93f76723 buildah-1.26.1.tar.gz
+b993821040788085ff44e48023a64cea4e3e7e50731c359087bd287168e6849a543d930acbdaff2437fc7951acc46f7183f337dd977215eca814332e6869d1e3 common-0.57.0.tar.gz
+89916b49438bce8bb774b4aa799676d4b3a946a0b5207a1b5241b1a3ac0875b06b3cd8e81d7e23332ceae6010b693516fc31d8c7f75a37e7ad3056a83c75b6c1 storage-1.51.0.tar.gz
+5e670f85fe0b43769667f1a3e710434ab65c4ec2d8c60b0cad4b0ed41c35f84677528f9dfecb0b946de556ebbdd56f4949760432ec49b1b3c691120a323af869 image-5.29.0.tar.gz
+2178a9c8428a0cf2c402e0f299efe2ad9a797143e641a92438112694a4acbdfb69ba8c104c87f4763d001f17cedb709eef24d86460d095a61a64d29a168a2051 podman-4.8.0.tar.gz
+59d329036a97cbeca4de20b15d9dd8adacd5201834b26ae5e5c88b05594b2a7101c22da91f22c35c07a98e41afa28f2c7103e660b3847c7f8c9691f27f4c4146 skopeo-1.14.0.tar.gz
+574c1a249d93edd5f89e106cd192da94235edcff097d9bce841e3b3b3a9588029deddaceb301505114b994e854016c72090cc0016a00ef027b25f3672a3fab32 buildah-1.33.2.tar.gz
+856dbbeb2acda276e9605bd1ecec0f8d65952c597ee2af61dd8909d7d3c04e5ef06c40b69ec4a98f79e623c536850f614c1b0af3a19637e300e7d3a285933193 shortnames-2023.02.20.tar.gz
"