aboutsummaryrefslogtreecommitdiffstats
path: root/community/coreaction/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coreaction/APKBUILD')
-rw-r--r--community/coreaction/APKBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/community/coreaction/APKBUILD b/community/coreaction/APKBUILD
index 0a90629d9bb..c428bf90e68 100644
--- a/community/coreaction/APKBUILD
+++ b/community/coreaction/APKBUILD
@@ -1,24 +1,36 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=coreaction
-pkgver=2.7.0
+pkgver=4.5.0
pkgrel=0
-pkgdesc="A side bar for showing widgets from the CoreApps family."
+pkgdesc="A side bar for showing widgets from C-Suite"
arch="all"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
-depends="qt5-qtsvg"
-makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+makedepends="
+ cmake
+ libcprime-dev
+ libcsys-dev
+ qt5-qtbase-dev
+ qt5-qtsvg-dev
+ samurai
+ "
+source="https://gitlab.com/cubocore/coreaction/-/archive/v$pkgver/coreaction-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"
+options="!check" # No tests
build() {
- qmake-qt5
- make
+ cmake -B build -GNinja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
}
package() {
- INSTALL_ROOT="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="7d077a7bd81fd52e373831108757466a9e6c7c9a87f07b538896bc5b696161c0e2428377813a809a2387b1b66705f158846463333e542624eaba02cf81b6c226 coreaction-2.7.0.tar.gz"
+
+sha512sums="
+d03744e5d88e78e827282e7afa73160cb4dce6021d09b2d182cb13e6bbfe144b17b531c47e1ca9921a10d415c4762b5689fb0f2251e03ced5a6bd7da90026770 coreaction-v4.5.0.tar.gz
+"