aboutsummaryrefslogtreecommitdiffstats
path: root/community/coreaction/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coreaction/APKBUILD')
-rw-r--r--community/coreaction/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/coreaction/APKBUILD b/community/coreaction/APKBUILD
index 12eb497f16d..c428bf90e68 100644
--- a/community/coreaction/APKBUILD
+++ b/community/coreaction/APKBUILD
@@ -1,15 +1,21 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=coreaction
-pkgver=4.2.0
-pkgrel=1
+pkgver=4.5.0
+pkgrel=0
pkgdesc="A side bar for showing widgets from C-Suite"
-# s390x, mips64 and riscv64 blocked by polkit -> libcsys
-arch="all !s390x !mips64 !riscv64"
+arch="all"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
-makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev qt5-qtsvg-dev cmake ninja"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/coreaction/-/archive/v$pkgver/coreaction-v$pkgver.tar.gz"
+makedepends="
+ cmake
+ libcprime-dev
+ libcsys-dev
+ qt5-qtbase-dev
+ qt5-qtsvg-dev
+ samurai
+ "
+source="https://gitlab.com/cubocore/coreaction/-/archive/v$pkgver/coreaction-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
options="!check" # No tests
@@ -24,4 +30,7 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="006ffd4791084b56fa87ce3630ab84018915f2c986b5b4a50ec7a8e42cb52bca22eb42e5952b22bde67b80b1494c4459598cc544e3fb415d3cd5f22e6056a7a6 coreaction-4.2.0.tar.gz"
+
+sha512sums="
+d03744e5d88e78e827282e7afa73160cb4dce6021d09b2d182cb13e6bbfe144b17b531c47e1ca9921a10d415c4762b5689fb0f2251e03ced5a6bd7da90026770 coreaction-v4.5.0.tar.gz
+"