aboutsummaryrefslogtreecommitdiffstats
path: root/community/coreaction/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coreaction/APKBUILD')
-rw-r--r--community/coreaction/APKBUILD34
1 files changed, 23 insertions, 11 deletions
diff --git a/community/coreaction/APKBUILD b/community/coreaction/APKBUILD
index b927b2f90f4..c428bf90e68 100644
--- a/community/coreaction/APKBUILD
+++ b/community/coreaction/APKBUILD
@@ -1,24 +1,36 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=coreaction
-pkgver=4.0.0
+pkgver=4.5.0
pkgrel=0
-pkgdesc="A side bar for showing widgets from the CoreApps family."
-arch="all !s390x" # polkit
+pkgdesc="A side bar for showing widgets from C-Suite"
+arch="all"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
-depends="qt5-qtsvg"
-makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev qt5-qtsvg-dev"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/coreaction/-/archive/v$pkgver/coreaction-v$pkgver.tar.gz"
+makedepends="
+ cmake
+ libcprime-dev
+ libcsys-dev
+ qt5-qtbase-dev
+ qt5-qtsvg-dev
+ samurai
+ "
+source="https://gitlab.com/cubocore/coreaction/-/archive/v$pkgver/coreaction-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"
+options="!check" # No tests
build() {
- qmake-qt5
- make
+ cmake -B build -GNinja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
}
package() {
- INSTALL_ROOT="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="47f4289bb69498f0d6ba0ba6b3cbf4cea3ccadf4adb0b57c77ccc26cb1b132ecb908291b0b0dc8dccdedbc5b5c2dec40d6adbfb65f73127df1fef868bba16c1e coreaction-4.0.0.tar.gz"
+
+sha512sums="
+d03744e5d88e78e827282e7afa73160cb4dce6021d09b2d182cb13e6bbfe144b17b531c47e1ca9921a10d415c4762b5689fb0f2251e03ced5a6bd7da90026770 coreaction-v4.5.0.tar.gz
+"