aboutsummaryrefslogtreecommitdiffstats
path: root/community/coredns/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coredns/APKBUILD')
-rw-r--r--community/coredns/APKBUILD37
1 files changed, 17 insertions, 20 deletions
diff --git a/community/coredns/APKBUILD b/community/coredns/APKBUILD
index 353ca910de8..6f66f461396 100644
--- a/community/coredns/APKBUILD
+++ b/community/coredns/APKBUILD
@@ -2,31 +2,36 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Mark Pashmfouroush <mark@markpash.me>
pkgname=coredns
-pkgver=1.8.7
-pkgrel=0
+pkgver=1.11.1
+pkgrel=5
pkgdesc="fast and flexible DNS server"
url="https://github.com/coredns/coredns"
license="Apache-2.0"
arch="all"
-options="net chmod-clean"
-makedepends="go libcap unbound-libs unbound-dev"
-depends="unbound-libs"
+makedepends="go unbound-dev"
install="$pkgname.pre-install"
subpackages="$pkgname-openrc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/coredns/coredns/archive/v$pkgver.tar.gz
+source="https://github.com/coredns/coredns/archive/v$pkgver/coredns-$pkgver.tar.gz
coredns.confd
coredns.initd
coredns.logrotated
ensure-cgo.patch
plugin.cfg.enabled
- fix-netbox-plugin.patch
"
+options="net" # for downloading Go modules
-export GOPATH="$srcdir"
+# secfixes:
+# 1.9.3-r0:
+# - CVE-2022-27191
+# - CVE-2022-28948
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
prepare() {
default_prepare
- cp $srcdir/plugin.cfg.enabled $builddir/plugin.cfg
+ cp "$srcdir"/plugin.cfg.enabled "$builddir"/plugin.cfg
}
build() {
@@ -42,7 +47,6 @@ check() {
package() {
install -Dm755 coredns "$pkgdir"/usr/bin/coredns
- setcap cap_net_bind_service=+ep "$pkgdir"/usr/bin/coredns
install -Dm755 "$srcdir"/coredns.initd "$pkgdir"/etc/init.d/coredns
install -Dm644 "$srcdir"/coredns.confd "$pkgdir"/etc/conf.d/coredns
@@ -52,18 +56,11 @@ package() {
install -d "$pkgdir"/var/log/coredns
}
-cleanup_srcdir() {
- export GOPATH="$srcdir"
- go clean -modcache
- default_cleanup_srcdir
-}
-
sha512sums="
-21f36a86af2d746a2c64ce0d16b9dd7ac64e742bea222212956160bd30396bc6d40555f2591c1a959cc08c8551e1872509ba001977b3eb4e7c15917a7c284bcd coredns-1.8.7.tar.gz
+f8752811e9e7913311f47ae13f35c755ac86ea240572be1c1dabc1712b6c42380c60ac385fa9573c77d6fcf4c144df2bc00574f18e8d7b70da21ed8ae4fb87cd coredns-1.11.1.tar.gz
90300a3035b00b58f362b2c12dfaeee21b889e10e90600523b5785c907dfbd7e515c3269dd29a9d4c758990e78ede8343edfac0bc022bd3a23652543ba2d42d3 coredns.confd
-06d9fcf227e064f8ea21f4f003d33611aabf2d75b2e6e097dc10af1db42ea823d15c26649e52584da4fb4a85e87b3f27959a44ce873f176c2a082624f6845f38 coredns.initd
+802ac66ea27ac71001706b0994a579e0ab3f608a89d0a03f92490f4b73c4bd202745fd13b34d957122c8f1439be2709604c7931ff2a7be003c573e746c9d98b9 coredns.initd
c697c08c3b1153ae224a1eeb3521f9ee594de4852bc6ef78d94dc7f6f680517659a653ab5c13ea03918deb79e6654ef11512ba4c90fe06ea4591fefbab876ece coredns.logrotated
9f2c08750b42f0901bc190a4c829a5a003e4c3aa9bd55e9a2f37f68f446cdd15b60227b7d2381d85b49674580f7c0206af76345d6dd5160401772c3efbf50ab6 ensure-cgo.patch
-6746632085004303d8c21628bcc34e98025a523ee0c4a0db589bae9d9c9ea1b403d84ee70dd7217154956be67d25344560319c8c3ac919370f0027c3092687df plugin.cfg.enabled
-8ece9c8b825de8d5bbcbaecacd0407c540f1fd55e6a22d7ca493e92f47b44caf28bd6d588b07affc26b1872dec0e1d97a4f0fb0462052b83e14a3d59189688eb fix-netbox-plugin.patch
+4c2ea139af034f1868a929e501a51ab7b8650426c250ee2e01fc1f8835b7f461a9999287aae83a43f13d6c2f7c4619979747e24a94bc47921e299e912aac43cc plugin.cfg.enabled
"