aboutsummaryrefslogtreecommitdiffstats
path: root/community/corestats/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/corestats/APKBUILD')
-rw-r--r--community/corestats/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/corestats/APKBUILD b/community/corestats/APKBUILD
index e375ce1831e..14c1a3cb25b 100644
--- a/community/corestats/APKBUILD
+++ b/community/corestats/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=corestats
-pkgver=4.3.0
+pkgver=4.5.0
pkgrel=0
pkgdesc="A system resource viewer from C-Suite"
-arch="all !s390x !riscv64" # blocked by libcsys
+# not useful on s390x
+arch="all !s390x"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev lm-sensors-dev cmake ninja"
source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/corestats/-/archive/v$pkgver/corestats-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"
+options="!check" # No test suite
build() {
cmake -B build \
@@ -27,5 +28,5 @@ package() {
}
sha512sums="
-ab8ebcc0bb3ec8501382b358dc2e31acb32ae400739c1131755fedb7f8964a79eaad6829126d0704d93dfa0c043fbf7c859f942fbb9323d8486f12dee5f87fa6 corestats-4.3.0.tar.gz
+68b1f653b90fa9c7f68cb9bf6075e682cbe42e148a371ffc2301a0160b4f75879cdf7e7805772b2a05cedd99b0b83ce2a98926ac48a1a0a36d12f05739090dff corestats-4.5.0.tar.gz
"