aboutsummaryrefslogtreecommitdiffstats
path: root/community/corestuff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/corestuff/APKBUILD')
-rw-r--r--community/corestuff/APKBUILD30
1 files changed, 22 insertions, 8 deletions
diff --git a/community/corestuff/APKBUILD b/community/corestuff/APKBUILD
index 9bfd0d9c269..164ce2099d8 100644
--- a/community/corestuff/APKBUILD
+++ b/community/corestuff/APKBUILD
@@ -1,19 +1,30 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=corestuff
-pkgver=4.2.0
+pkgver=4.5.0
pkgrel=0
pkgdesc="An activity viewer from C-Suite"
-# s390x, mips64 and riscv64 blocked by polkit -> libcsys
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by extra-cmake-modules -> kglobalaccel
+arch="all !armhf"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
-makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev qt5-qtx11extras-dev
- libxcomposite-dev kglobalaccel-dev libxi-dev xcb-util-wm-dev xcb-util-dev cmake ninja"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/corestuff/-/archive/v$pkgver/corestuff-v$pkgver.tar.gz"
+makedepends="
+ cmake
+ kglobalaccel5-dev
+ libcprime-dev
+ libcsys-dev
+ libxcomposite-dev
+ libxi-dev
+ qt5-qtbase-dev
+ qt5-qtx11extras-dev
+ samurai
+ xcb-util-dev
+ xcb-util-wm-dev
+ "
+source="https://gitlab.com/cubocore/corestuff/-/archive/v$pkgver/corestuff-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
-options="!check"
+options="!check" # No test suite
build() {
cmake -B build -GNinja \
@@ -26,4 +37,7 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="88a7d5035b05d7b74a0dbe38b01c01b84cf614e7188ab94cf287828839a7210b622b8be48f3064b4e0f1fd77d13ba065a7ba5faee32e6f056c79706c6a11bb22 corestuff-4.2.0.tar.gz"
+
+sha512sums="
+eba12784dd320f4b6ebd8221f58ac8beb90becc2b187d486a3c3ac2bdc9ceee630ec2eb6761b2b0021b841c5b17c76648b08a4d4e949f15e52dcc4f3e5675bf0 corestuff-v4.5.0.tar.gz
+"