aboutsummaryrefslogtreecommitdiffstats
path: root/community/coretoppings/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coretoppings/APKBUILD')
-rw-r--r--community/coretoppings/APKBUILD38
1 files changed, 29 insertions, 9 deletions
diff --git a/community/coretoppings/APKBUILD b/community/coretoppings/APKBUILD
index 57e0cc1ad02..af600d15947 100644
--- a/community/coretoppings/APKBUILD
+++ b/community/coretoppings/APKBUILD
@@ -1,25 +1,45 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=coretoppings
-pkgver=4.0.0
+pkgver=4.5.0
pkgrel=0
-pkgdesc="An activity viewer from the CoreApps family."
-arch="all !armhf !s390x" # qt5-qtlocation, polkit
+pkgdesc="An activity viewer from the CoreApps family"
+# armhf blocked by qt5-qtlocation
+arch="all !armhf"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
-makedepends="qt5-qtbase-dev libcprime-dev qt5-qtx11extras-dev qt5-qtconnectivity-dev qt5-qtlocation-dev libcsys-dev libxcomposite-dev xcb-util-dev libxrender-dev xcb-util-wm-dev"
-source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/coretoppings/-/archive/v$pkgver/coretoppings-v$pkgver.tar.gz"
+makedepends="
+ cmake
+ libcprime-dev
+ libcsys-dev
+ libdbusmenu-qt-dev
+ libxcomposite-dev
+ libxrender-dev
+ qt5-qtbase-dev
+ qt5-qtconnectivity-dev
+ qt5-qtlocation-dev
+ qt5-qtx11extras-dev
+ samurai
+ xcb-util-dev
+ xcb-util-wm-dev
+ "
+source="https://gitlab.com/cubocore/coretoppings/-/archive/v$pkgver/coretoppings-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
options="!check" # No test suite
build() {
- qmake-qt5
- make
+ cmake -B build -GNinja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=None
+ cmake --build build
}
package() {
- INSTALL_ROOT="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="469eacf5fa33388d57f7f3b0b84886fee97942b2d77418e454334f62dcaad891f499ec9b5bf4930b46757a2ec67b3cc2f1656530804811ac6eff74c25d110536 coretoppings-4.0.0.tar.gz"
+sha512sums="
+1467e5d5e61ca50fb6767b619115776c101a504c4b6b137be923352110f99f602d9bb30341af7c635524990121fc402bc547cbbc6a237859be3a01e6c75daf59 coretoppings-v4.5.0.tar.gz
+"