aboutsummaryrefslogtreecommitdiffstats
path: root/community/coretoppings/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/coretoppings/APKBUILD')
-rw-r--r--community/coretoppings/APKBUILD23
1 files changed, 18 insertions, 5 deletions
diff --git a/community/coretoppings/APKBUILD b/community/coretoppings/APKBUILD
index 36fa8aa1163..af600d15947 100644
--- a/community/coretoppings/APKBUILD
+++ b/community/coretoppings/APKBUILD
@@ -1,16 +1,29 @@
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname=coretoppings
-pkgver=4.2.0
+pkgver=4.5.0
pkgrel=0
pkgdesc="An activity viewer from the CoreApps family"
# armhf blocked by qt5-qtlocation
-# s390x, mips64 and riscv64 blocked by polkit -> libcsys
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
-makedepends="qt5-qtbase-dev libcprime-dev qt5-qtx11extras-dev qt5-qtconnectivity-dev qt5-qtlocation-dev libcsys-dev libdbusmenu-qt-dev libxcomposite-dev xcb-util-dev libxrender-dev xcb-util-wm-dev cmake ninja"
+makedepends="
+ cmake
+ libcprime-dev
+ libcsys-dev
+ libdbusmenu-qt-dev
+ libxcomposite-dev
+ libxrender-dev
+ qt5-qtbase-dev
+ qt5-qtconnectivity-dev
+ qt5-qtlocation-dev
+ qt5-qtx11extras-dev
+ samurai
+ xcb-util-dev
+ xcb-util-wm-dev
+ "
source="https://gitlab.com/cubocore/coretoppings/-/archive/v$pkgver/coretoppings-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
options="!check" # No test suite
@@ -28,5 +41,5 @@ package() {
}
sha512sums="
-f3d433db645308183e51fb250895088e6fca6d32f1d1ffcf8e758d749daa09a96707549d4b51c8ac51711481e78d7c4be1d4dfe496f32dd28bd14cb0b5da4af7 coretoppings-v4.2.0.tar.gz
+1467e5d5e61ca50fb6767b619115776c101a504c4b6b137be923352110f99f602d9bb30341af7c635524990121fc402bc547cbbc6a237859be3a01e6c75daf59 coretoppings-v4.5.0.tar.gz
"