aboutsummaryrefslogtreecommitdiffstats
path: root/community/cpd
diff options
context:
space:
mode:
Diffstat (limited to 'community/cpd')
-rw-r--r--community/cpd/0001-Stop-forcing-static-builds.patch27
-rw-r--r--community/cpd/APKBUILD41
2 files changed, 68 insertions, 0 deletions
diff --git a/community/cpd/0001-Stop-forcing-static-builds.patch b/community/cpd/0001-Stop-forcing-static-builds.patch
new file mode 100644
index 00000000000..a87b653aa22
--- /dev/null
+++ b/community/cpd/0001-Stop-forcing-static-builds.patch
@@ -0,0 +1,27 @@
+From 01a66a7d14f3e0ba328d8e0dd2dd597762bc5698 Mon Sep 17 00:00:00 2001
+From: Bart Ribbers <bribbers@disroot.org>
+Date: Wed, 5 May 2021 13:38:00 +0200
+Subject: [PATCH] Stop forcing static builds
+
+When not hardcoding static, the library can be build with shared libs or
+without, depending on what value the user passes to -DBUILD_SHARED_LIBS
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3da0c8d..cff4da2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -66,7 +66,7 @@ else()
+ list(APPEND library-src src/gauss_transform_make_default.cpp)
+ endif()
+
+-add_library(Library-C++ STATIC ${library-src})
++add_library(Library-C++ ${library-src})
+ set_target_properties(Library-C++ PROPERTIES
+ OUTPUT_NAME cpd
+ VERSION ${CPD_VERSION}
+--
+2.31.1
+
diff --git a/community/cpd/APKBUILD b/community/cpd/APKBUILD
new file mode 100644
index 00000000000..6a7d3442eb0
--- /dev/null
+++ b/community/cpd/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Bradley J Chambers <brad.chambers@gmail.com>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=cpd
+pkgver=0.5.5
+pkgrel=0
+pkgdesc="C++ implementation of the Coherent Point Drift point set registration algorithm."
+url="https://github.com/gadomski/cpd"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="
+ cmake
+ eigen-dev
+ fgt-dev
+ samurai
+ "
+subpackages="$pkgname-dev"
+source="https://github.com/gadomski/cpd/archive/v$pkgver/cpd-v$pkgver.tar.gz
+ 0001-Stop-forcing-static-builds.patch
+ "
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -DWITH_TESTS=ON \
+ -DBUILD_SHARED_LIBS=ON
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+aba4cc84f3f468d57133c200c31797573a198c75d23004b619762b8f910bf73c1334b7d7bd021159c1f15e77376751a04d7a97837daff0ae72aed52d6a1f9c6a cpd-v0.5.5.tar.gz
+c9fc897486d2db611946fa060d31ac7a010dd92ffd456ccc4161bad4f5225fdc1fea2410718448a88b98d65187069e22740d00501ed15b0e1798327d3b8b7e22 0001-Stop-forcing-static-builds.patch
+"