aboutsummaryrefslogtreecommitdiffstats
path: root/community/cpptest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cpptest/APKBUILD')
-rw-r--r--community/cpptest/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/cpptest/APKBUILD b/community/cpptest/APKBUILD
index da6ea10dc21..65b6fd6db79 100644
--- a/community/cpptest/APKBUILD
+++ b/community/cpptest/APKBUILD
@@ -2,28 +2,29 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=cpptest
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Portable and powerful unit testing framework for handling automated tests in C++"
url="https://github.com/cpptest/cpptest"
arch="all"
license="LGPL-2.0-or-later"
subpackages="$pkgname-dev"
source="https://github.com/cpptest/cpptest/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_guess
+}
build() {
- cd "$builddir"
./configure --prefix=/usr
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
}