aboutsummaryrefslogtreecommitdiffstats
path: root/community/cpputest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cpputest/APKBUILD')
-rw-r--r--community/cpputest/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/cpputest/APKBUILD b/community/cpputest/APKBUILD
index 1857e3be3ed..2ed5dc54411 100644
--- a/community/cpputest/APKBUILD
+++ b/community/cpputest/APKBUILD
@@ -2,30 +2,30 @@
# Maintainer: Shiva Velmurugan <shiv@shiv.me>
pkgname=cpputest
pkgver=4.0
-pkgrel=0
+pkgrel=1
pkgdesc="A unit testing and mocking framework for C/C++"
url="http://cpputest.github.io/"
-arch="all !mips !mips64" # FTBFS on soft-float (mips)
+arch="all"
license="BSD-3-Clause"
-options="!dbg"
-makedepends="cmake"
-subpackages="$pkgname-static"
+makedepends="cmake samurai"
source="https://github.com/cpputest/cpputest/releases/download/v$pkgver/cpputest-$pkgver.tar.gz"
build() {
- cmake -B build . \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- make -C build
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DC++11=ON \
+ -DLONGLONG=ON
+ cmake --build build
}
check() {
- make -C build test
+ ninja -C build test
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
mkdir -p "$pkgdir"/usr/lib/cmake
mv "$pkgdir"/usr/lib/CppUTest/cmake \
@@ -33,4 +33,6 @@ package() {
rmdir "$pkgdir"/usr/lib/CppUTest
}
-sha512sums="69f39fffdcd965c871e598118db38ddb74a3e75fd7a7965f8d236029fa891f6fcb6b671147c166ad08482bbd0737537fafe90aa8439a0ab62389f19150cc39d7 cpputest-4.0.tar.gz"
+sha512sums="
+69f39fffdcd965c871e598118db38ddb74a3e75fd7a7965f8d236029fa891f6fcb6b671147c166ad08482bbd0737537fafe90aa8439a0ab62389f19150cc39d7 cpputest-4.0.tar.gz
+"