aboutsummaryrefslogtreecommitdiffstats
path: root/community/cpufrequtils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cpufrequtils/APKBUILD')
-rw-r--r--community/cpufrequtils/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/community/cpufrequtils/APKBUILD b/community/cpufrequtils/APKBUILD
index 028bf74e993..4b0ecaf5984 100644
--- a/community/cpufrequtils/APKBUILD
+++ b/community/cpufrequtils/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cpufrequtils
pkgver=008
-pkgrel=4
+pkgrel=6
pkgdesc="Userspace tools for the kernel cpufreq subsystem"
-url="https://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils.html"
+url="https://www.kernel.org/pub/linux/utils/kernel/cpufreq/"
arch="all"
license="GPL-2.0"
subpackages="$pkgname-dev $pkgname-doc"
@@ -24,7 +24,7 @@ prepare() {
cd "$srcdir"/$pkgname-$pkgver
for i in ../*.patch; do
msg "Applying $i..."
- patch -p1 < $i || return 1
+ patch -p1 < $i
done
}
@@ -34,8 +34,7 @@ build() {
# we save 4k by disabling the 2.4 kernel support (PROC=false)
make -j1 LIBTOOL_OPT="--tag=CC --silent" \
NLS=false \
- PROC=false \
- || return 1
+ PROC=false
}
package() {
@@ -44,7 +43,7 @@ package() {
NLS=false \
INSTALL=install \
DESTDIR="$pkgdir" \
- install || return 1
+ install
install -D -m755 ../$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -D -m644 ../$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}