aboutsummaryrefslogtreecommitdiffstats
path: root/community/cronie/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cronie/APKBUILD')
-rw-r--r--community/cronie/APKBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/community/cronie/APKBUILD b/community/cronie/APKBUILD
index a8e56928874..0279c7f2b2a 100644
--- a/community/cronie/APKBUILD
+++ b/community/cronie/APKBUILD
@@ -1,21 +1,26 @@
# Contributor: Mark Hills <mark@xwax.org>
-# Maintainer: Mark Hills <mark@xwax.org>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=cronie
-pkgver=1.5.7
+pkgver=1.7.2
pkgrel=0
pkgdesc="The standard UNIX daemon crond that runs specified programs at scheduled times"
url="https://github.com/cronie-crond/cronie"
arch="all"
license="ISC"
-makedepends="autoconf automake musl-obstack-dev"
+install="$pkgname-openrc.post-install"
+makedepends="musl-obstack-dev"
options="suid !check" # No testsuite
subpackages="$pkgname-doc $pkgname-openrc"
-source="
- https://github.com/cronie-crond/cronie/releases/download/cronie-$pkgver/cronie-$pkgver.tar.gz
+source="https://github.com/cronie-crond/cronie/releases/download/cronie-$pkgver/cronie-$pkgver.tar.gz
cronie.initd
cronie.confd
"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
export LIBS="-lobstack"
./configure \
@@ -33,11 +38,11 @@ build() {
}
package() {
- make install DESTDIR="$pkgdir"
+ make DESTDIR="$pkgdir" install
- install -m755 -D "$srcdir"/$pkgname.initd \
+ install -Dm755 "$srcdir"/cronie.initd \
"$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd \
+ install -Dm644 "$srcdir"/cronie.confd \
"$pkgdir"/etc/conf.d/$pkgname
mkdir "$pkgdir"/etc/cron.d
@@ -49,6 +54,8 @@ package() {
touch "$pkgdir"/etc/cron.deny
}
-sha512sums="c306468d2e8d618a168e55204796f15d845520130d9601395e6413c55a71e94b4264a73e2e3f5d7011b3e53af9dad812f56662de3a7c9e50977d57b2a49a6893 cronie-1.5.7.tar.gz
-309ac59de5212e814e8f68f0619e91a1459092392dd38d85c72740c635a6e50f232cfcdb883eccff203c7254bc94f60fe203150137a0862c3802ace58d5fcc22 cronie.initd
-caabbeb35c8bfed5f139063416cb6667ab066918e8ef57b057bf4d7bbb005ad6cc5d34687e52ed22f8152e61f4c35709e895652497600a7194cdfb04d48ca152 cronie.confd"
+sha512sums="
+5b55c677a5b812dbfa70f6ee25e41907e99cc63a4883974c6bb8115ad65155d66665704808c338d2f7be6b0a57028c319f2d1115c69bb5f3efdda1efafd144de cronie-1.7.2.tar.gz
+ea0795420bc2a9c770c2950c066dc19655056c9e4e6d7277d5deade5144b988f2df806fe025a8fce67fe9bab73a25332f141395c222f2d2a62a41a874ce98dc8 cronie.initd
+caabbeb35c8bfed5f139063416cb6667ab066918e8ef57b057bf4d7bbb005ad6cc5d34687e52ed22f8152e61f4c35709e895652497600a7194cdfb04d48ca152 cronie.confd
+"