aboutsummaryrefslogtreecommitdiffstats
path: root/community/cronie/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cronie/APKBUILD')
-rw-r--r--community/cronie/APKBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/community/cronie/APKBUILD b/community/cronie/APKBUILD
new file mode 100644
index 00000000000..0279c7f2b2a
--- /dev/null
+++ b/community/cronie/APKBUILD
@@ -0,0 +1,61 @@
+# Contributor: Mark Hills <mark@xwax.org>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=cronie
+pkgver=1.7.2
+pkgrel=0
+pkgdesc="The standard UNIX daemon crond that runs specified programs at scheduled times"
+url="https://github.com/cronie-crond/cronie"
+arch="all"
+license="ISC"
+install="$pkgname-openrc.post-install"
+makedepends="musl-obstack-dev"
+options="suid !check" # No testsuite
+subpackages="$pkgname-doc $pkgname-openrc"
+source="https://github.com/cronie-crond/cronie/releases/download/cronie-$pkgver/cronie-$pkgver.tar.gz
+ cronie.initd
+ cronie.confd
+ "
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ export LIBS="-lobstack"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --without-pam \
+ --without-selinux \
+ --with-inotify \
+ SPOOL_DIR=/etc/crontabs
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+
+ install -Dm755 "$srcdir"/cronie.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+ install -Dm644 "$srcdir"/cronie.confd \
+ "$pkgdir"/etc/conf.d/$pkgname
+
+ mkdir "$pkgdir"/etc/cron.d
+
+ # Ordinary users access to edit content of the crontabs directory
+ chmod 6755 "$pkgdir"/usr/bin/crontab
+
+ # Default is all users can access cron
+ touch "$pkgdir"/etc/cron.deny
+}
+
+sha512sums="
+5b55c677a5b812dbfa70f6ee25e41907e99cc63a4883974c6bb8115ad65155d66665704808c338d2f7be6b0a57028c319f2d1115c69bb5f3efdda1efafd144de cronie-1.7.2.tar.gz
+ea0795420bc2a9c770c2950c066dc19655056c9e4e6d7277d5deade5144b988f2df806fe025a8fce67fe9bab73a25332f141395c222f2d2a62a41a874ce98dc8 cronie.initd
+caabbeb35c8bfed5f139063416cb6667ab066918e8ef57b057bf4d7bbb005ad6cc5d34687e52ed22f8152e61f4c35709e895652497600a7194cdfb04d48ca152 cronie.confd
+"