aboutsummaryrefslogtreecommitdiffstats
path: root/community/crun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/crun/APKBUILD')
-rw-r--r--community/crun/APKBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/community/crun/APKBUILD b/community/crun/APKBUILD
index fb32889e171..c8d938f6ce7 100644
--- a/community/crun/APKBUILD
+++ b/community/crun/APKBUILD
@@ -2,16 +2,29 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=crun
-pkgver=0.21
+pkgver=1.14.4
pkgrel=0
pkgdesc="Fast and lightweight fully featured OCI runtime and C library for running containers"
url="https://github.com/containers/crun"
-arch="all"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
+arch="all"
makedepends="libcap-dev libseccomp-dev yajl-dev argp-standalone python3 go-md2man"
subpackages="$pkgname-doc $pkgname-static"
source="https://github.com/containers/crun/releases/download/$pkgver/crun-$pkgver.tar.xz"
+provides="oci-runtime"
+provider_priority=100 # highest, default provider
+
+# secfixes:
+# 1.4.4-r0:
+# - CVE-2022-27650
+
+prepare() {
+ default_prepare
+ update_config_sub
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
@@ -28,5 +41,5 @@ package() {
}
sha512sums="
-6fab3e42b18e16ada4f4ccb425f01200bc0959d7aa12f22f77a0f56054fc967501208ec42c54c0120e54fd0aadd7697687fc43eb9d3befa6b5d4e0c6c7f4c8c2 crun-0.21.tar.xz
+1681ea85de3540958b4d7efadcf22c6f47c991fc4681a5028404952567c0b1b0220ad0ce0e0f0d727da27d8e63495a8bfc43a13b3511b1455106fdfec2e32e49 crun-1.14.4.tar.xz
"