aboutsummaryrefslogtreecommitdiffstats
path: root/community/crun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/crun/APKBUILD')
-rw-r--r--community/crun/APKBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/community/crun/APKBUILD b/community/crun/APKBUILD
index 43b611a4deb..c8d938f6ce7 100644
--- a/community/crun/APKBUILD
+++ b/community/crun/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=crun
-pkgver=1.2
+pkgver=1.14.4
pkgrel=0
pkgdesc="Fast and lightweight fully featured OCI runtime and C library for running containers"
url="https://github.com/containers/crun"
@@ -12,6 +12,19 @@ makedepends="libcap-dev libseccomp-dev yajl-dev argp-standalone python3 go-md2ma
subpackages="$pkgname-doc $pkgname-static"
source="https://github.com/containers/crun/releases/download/$pkgver/crun-$pkgver.tar.xz"
+provides="oci-runtime"
+provider_priority=100 # highest, default provider
+
+# secfixes:
+# 1.4.4-r0:
+# - CVE-2022-27650
+
+prepare() {
+ default_prepare
+ update_config_sub
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
@@ -28,5 +41,5 @@ package() {
}
sha512sums="
-dab4aab346f410da324fc6d6944778575d8dd7d1590a8ef42898fd883cbd062f9f9cbe69bdbf74e576050d2c1a36b14a48baffbf0e8e893176bfbcb28f851347 crun-1.2.tar.xz
+1681ea85de3540958b4d7efadcf22c6f47c991fc4681a5028404952567c0b1b0220ad0ce0e0f0d727da27d8e63495a8bfc43a13b3511b1455106fdfec2e32e49 crun-1.14.4.tar.xz
"