aboutsummaryrefslogtreecommitdiffstats
path: root/community/csview/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/csview/APKBUILD')
-rw-r--r--community/csview/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/community/csview/APKBUILD b/community/csview/APKBUILD
index 2acd925c236..2067c0bde79 100644
--- a/community/csview/APKBUILD
+++ b/community/csview/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=csview
-pkgver=1.0.1
+pkgver=1.3.0
pkgrel=0
pkgdesc="Pretty csv viewer for cli with cjk/emoji support"
url="https://github.com/wfxr/csview"
-arch="aarch64 armhf armv7 ppc64le x86 x86_64" # blocked by rust/cargo
+arch="all"
license="Apache-2.0 OR MIT"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
subpackages="
$pkgname-bash-completion
$pkgname-fish-completion
@@ -15,19 +15,14 @@ subpackages="
"
source="https://github.com/wfxr/csview/archive/v$pkgver/csview-$pkgver.tar.gz"
-export CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
-export CARGO_PROFILE_RELEASE_LTO="true"
-export CARGO_PROFILE_RELEASE_OPT_LEVEL="s"
-export CARGO_PROFILE_RELEASE_PANIC="abort"
-
prepare() {
default_prepare
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --frozen --release
+ cargo auditable build --frozen --release
}
check() {
@@ -40,10 +35,10 @@ package() {
install -D -m644 completions/bash/$pkgname.bash \
"$pkgdir"/usr/share/bash-completion/completions/$pkgname
- install -D -m644 completions/fish/* -t "$pkgdir"/usr/share/fish/completions/
+ install -D -m644 completions/fish/* -t "$pkgdir"/usr/share/fish/vendor_completions.d/
install -D -m644 completions/zsh/* -t "$pkgdir"/usr/share/zsh/site-functions/
}
sha512sums="
-c1b0e5d4b97ba5078dda7145b2a130e0bf804332232c9b8625f003e72afe4b8aaebf724e0eeb3f462005dd7c06a28303f85e6714d20ba685e114c7e2edb05342 csview-1.0.1.tar.gz
+6ca060089a4cbf20a46a0f9e23d8f38b2366a88e0fd6054b40cd1532615164330829201c776d1e14b35f354e8bc4ca0ba8825e835ce3f62a0faae2714d3a8a18 csview-1.3.0.tar.gz
"