aboutsummaryrefslogtreecommitdiffstats
path: root/community/ctop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ctop/APKBUILD')
-rw-r--r--community/ctop/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/ctop/APKBUILD b/community/ctop/APKBUILD
new file mode 100644
index 00000000000..842883a11e2
--- /dev/null
+++ b/community/ctop/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Shyam Sunder <sgsunder1@gmail.com>
+# Maintainer: Shyam Sunder <sgsunder1@gmail.com>
+pkgname=ctop
+pkgver=0.7.7
+pkgrel=18
+pkgdesc="Top-like interface for container metrics"
+url="https://ctop.sh/"
+license="MIT"
+arch="all"
+makedepends="go"
+options="chmod-clean !check" # no test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/bcicen/ctop/archive/refs/tags/v$pkgver.tar.gz
+ enable-cgo.patch"
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ make build
+}
+
+package() {
+ install -Dm755 ctop "$pkgdir"/usr/bin/ctop
+}
+
+sha512sums="
+9924c4dc5da489f90b029bc8060e759edf02a170e17bbc9f9c29b6536e5bc3e5eec69af829c7662a1f69cd331fc24022cae8b30e865a07742fd7e3623bc7f33f ctop-0.7.7.tar.gz
+79150ad8b276bbe21d90a42aa658e6cc5735eccacdef53d94476b6e693b0496bbb77df223e8ef0d6eee74c785560ffab72547b265340947712c52121725d7fa3 enable-cgo.patch
+"