aboutsummaryrefslogtreecommitdiffstats
path: root/community/cyanrip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/cyanrip/APKBUILD')
-rw-r--r--community/cyanrip/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/cyanrip/APKBUILD b/community/cyanrip/APKBUILD
new file mode 100644
index 00000000000..3eee5dab8d0
--- /dev/null
+++ b/community/cyanrip/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Sodface <sod@sodface.com>
+# Maintainer: Sodface <sod@sodface.com>
+pkgname=cyanrip
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="Bule-ish CD ripper"
+url="https://github.com/cyanreg/cyanrip"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="
+ curl-dev
+ ffmpeg-dev
+ libcdio-dev
+ libcdio-paranoia-dev
+ libmusicbrainz-dev
+ meson
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/cyanreg/cyanrip/archive/refs/tags/v$pkgver.tar.gz"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+bae86ab799a28f5bbdfaf664c03a66c3c2d9c296239811163cbc04f1ce42646e086f33e505ceeb379ffb289d6b89f66f0abd6d36b323e873f9aae97878a3fc2e cyanrip-0.9.2.tar.gz
+"