aboutsummaryrefslogtreecommitdiffstats
path: root/community/dasel/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dasel/APKBUILD')
-rw-r--r--community/dasel/APKBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/community/dasel/APKBUILD b/community/dasel/APKBUILD
index 0af322ab3ad..2414ce2b9b8 100644
--- a/community/dasel/APKBUILD
+++ b/community/dasel/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=dasel
-pkgver=1.22.1
-pkgrel=0
+pkgver=2.6.0
+pkgrel=2
pkgdesc="Query and modify data structures using selector strings"
url="https://daseldocs.tomwright.me/"
license="MIT"
@@ -10,15 +10,14 @@ arch="all"
makedepends="go"
source="https://github.com/TomWright/dasel/archive/v$pkgver/dasel-$pkgver.tar.gz"
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -modcacherw"
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- go build \
- -ldflags "-X github.com/tomwright/dasel/internal.Version=$pkgver" \
- -v \
- ./cmd/dasel
+ go build -ldflags "
+ -X github.com/tomwright/dasel/internal.Version=$pkgver
+ " ./cmd/dasel
}
check() {
@@ -26,9 +25,9 @@ check() {
}
package() {
- install -Dm755 dasel "$pkgdir"/usr/bin/dasel
+ install -Dm755 dasel -t "$pkgdir"/usr/bin/
}
sha512sums="
-5de312a1aa5bab986b0b076c65a0ee1c7ffda8b080b2cb74416c89164b89b820e1d24f7b3fdbbe7e0084edfbf574722d5d2bd016c73a1f75da484e585df94f8e dasel-1.22.1.tar.gz
+fae8e5d241ac5e2596170f122d81e7590de5ff39782b08748ca22ecc6b3fde119c5dd1a3e7c66eb02e4d7583eb2cc266580eea85f24fcb88484b310cfd725dd1 dasel-2.6.0.tar.gz
"