aboutsummaryrefslogtreecommitdiffstats
path: root/community/date/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/date/APKBUILD')
-rw-r--r--community/date/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/community/date/APKBUILD b/community/date/APKBUILD
index 0e20a9360f8..5f6339fa329 100644
--- a/community/date/APKBUILD
+++ b/community/date/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname=date
-pkgver=3.0.0
-pkgrel=0
+pkgver=3.0.1
+pkgrel=2
pkgdesc="Date and time library based on the C++11/14/17 <chrono> header"
arch="all"
url="https://howardhinnant.github.io/date/date.html"
license="MIT"
-makedepends="cmake"
+makedepends="cmake samurai"
checkdepends="bash"
source="https://github.com/HowardHinnant/date/archive/v$pkgver/date-v$pkgver.tar.gz
538-output-date-pc-for-pkg-config.patch
@@ -15,7 +15,7 @@ subpackages="$pkgname-dev"
options="!check" # Several tests fail - see also https://github.com/HowardHinnant/date/issues/334
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -34,5 +34,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="03ba0faef68e053aba888591b9350af1a043ef543825c80b1ca3f0dc0448697f56286e561f1a2a59e684680d7fc1e51fd24955c4cc222fe28db64f56037dc1aa date-v3.0.0.tar.gz
-c92e9bc76554859687b0d1a7b0e09ab1044cc46a208e57ea112fcc87d5ed1e8fd21b195079dacbc17adf7830dd4e0b10deb67859263c26822f57225316c27e10 538-output-date-pc-for-pkg-config.patch"
+sha512sums="
+6bdc7cba821d66e17a559250cc0ce0095808e9db81cec9e16eaa4c31abdfa705299c67b72016d9b06b302bc306d063e83a374eb00728071b83a5ad650d59034f date-v3.0.1.tar.gz
+c92e9bc76554859687b0d1a7b0e09ab1044cc46a208e57ea112fcc87d5ed1e8fd21b195079dacbc17adf7830dd4e0b10deb67859263c26822f57225316c27e10 538-output-date-pc-for-pkg-config.patch
+"