aboutsummaryrefslogtreecommitdiffstats
path: root/community/date/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/date/APKBUILD')
-rw-r--r--community/date/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/date/APKBUILD b/community/date/APKBUILD
index 6e310769f34..5f6339fa329 100644
--- a/community/date/APKBUILD
+++ b/community/date/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname=date
pkgver=3.0.1
-pkgrel=0
+pkgrel=2
pkgdesc="Date and time library based on the C++11/14/17 <chrono> header"
arch="all"
url="https://howardhinnant.github.io/date/date.html"
license="MIT"
-makedepends="cmake"
+makedepends="cmake samurai"
checkdepends="bash"
source="https://github.com/HowardHinnant/date/archive/v$pkgver/date-v$pkgver.tar.gz
538-output-date-pc-for-pkg-config.patch
@@ -15,7 +15,7 @@ subpackages="$pkgname-dev"
options="!check" # Several tests fail - see also https://github.com/HowardHinnant/date/issues/334
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \