aboutsummaryrefslogtreecommitdiffstats
path: root/community/dateutils
diff options
context:
space:
mode:
Diffstat (limited to 'community/dateutils')
-rw-r--r--community/dateutils/APKBUILD21
-rw-r--r--community/dateutils/remove-sysctl-include.patch12
2 files changed, 19 insertions, 14 deletions
diff --git a/community/dateutils/APKBUILD b/community/dateutils/APKBUILD
index 4c5fb661013..fa18a29a235 100644
--- a/community/dateutils/APKBUILD
+++ b/community/dateutils/APKBUILD
@@ -1,30 +1,24 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=dateutils
-pkgver=0.4.1
+pkgver=0.4.2
pkgrel=0
pkgdesc="Utilities for fast date-time calculations and conversion"
url="http://hroptatyr.github.com/dateutils/"
arch="all"
license="BSD"
-depends=""
-makedepends="m4 texinfo automake autoconf"
-install=""
+makedepends="m4 texinfo automake autoconf linux-headers"
subpackages="$pkgname-doc"
-source="https://bitbucket.org/hroptatyr/$pkgname/downloads/$pkgname-${pkgver}.tar.xz"
+source="https://bitbucket.org/hroptatyr/$pkgname/downloads/$pkgname-${pkgver}.tar.xz
+ remove-sysctl-include.patch"
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- default_prepare || return 1
- update_config_guess
-}
-
build() {
cd "$builddir"
./configure \
--prefix=/usr \
--enable-static=no
- make || return 1
+ make
}
package() {
@@ -34,6 +28,5 @@ package() {
sed -n '/* Copyright/,/ DAMAGE.$/p' src/dadd.c > "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-md5sums="61262ed30187767b4c0130069816f777 dateutils-0.4.1.tar.xz"
-sha256sums="6ccce48975fc4d3af2e27c7893e181c46ab5df1cb37e4a428b4b521a77d55278 dateutils-0.4.1.tar.xz"
-sha512sums="c13461de6dad483b0014692a2319a7bf9ed1677415b8ee168131b397086f75725eb8b4e833d8b4a22f4aa726d6aca74be2597c2e07ef75a036cfea9bf67ccf1b dateutils-0.4.1.tar.xz"
+sha512sums="0b6e98bd9402dc3629122c3d68ab54df547ce779806661cc01df3625ab7cedb429d943ef46e151653283c1ac6c557f4bf14b3b5adaafbcac1d0a86c6d12895fd dateutils-0.4.2.tar.xz
+a31647222867996e23fa8066d13cfe19a4aac7d9ec86b0f998665ba60883454a1843edabd9f49af4a313a582b33cb043b8dead66cbdb4b72bd4918fac435543d remove-sysctl-include.patch"
diff --git a/community/dateutils/remove-sysctl-include.patch b/community/dateutils/remove-sysctl-include.patch
new file mode 100644
index 00000000000..f8299171950
--- /dev/null
+++ b/community/dateutils/remove-sysctl-include.patch
@@ -0,0 +1,12 @@
+diff --git a/build-aux/yuck.c b/build-aux/yuck.c
+index 0a19424..1e496e2 100644
+--- a/build-aux/yuck.c
++++ b/build-aux/yuck.c
+@@ -62,7 +62,6 @@
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+-#include <sys/sysctl.h>
+ #include <time.h>
+ #if defined WITH_SCMVER
+ # include <yuck-scmver.h>