aboutsummaryrefslogtreecommitdiffstats
path: root/community/desktop-file-utils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/desktop-file-utils/APKBUILD')
-rw-r--r--community/desktop-file-utils/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/desktop-file-utils/APKBUILD b/community/desktop-file-utils/APKBUILD
index f36b52ee2bd..57c6d18edd1 100644
--- a/community/desktop-file-utils/APKBUILD
+++ b/community/desktop-file-utils/APKBUILD
@@ -1,27 +1,36 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=desktop-file-utils
-pkgver=0.26
+pkgver=0.27
pkgrel=0
pkgdesc="Command line utilities for working with desktop entries"
-url="http://www.freedesktop.org/wiki/Software/desktop-file-utils"
+url="https://www.freedesktop.org/wiki/Software/desktop-file-utils"
arch="all"
license="GPL-2.0-or-later"
makedepends="glib-dev gettext-dev meson"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-emacs::noarch"
triggers="$pkgname.trigger=/usr/share/applications"
source="https://www.freedesktop.org/software/desktop-file-utils/releases/desktop-file-utils-$pkgver.tar.xz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="5b4e435f0b635d8f898ac7f5759f74a08ffbe2a56d41fee0e84ff57e73b98d08b57b4416f20b99f696dad8bcb1c20792b39acf836b0814220c0b386ea5f6b831 desktop-file-utils-0.26.tar.xz"
+emacs() {
+ pkgdesc="Emacs mode for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel emacs"
+
+ amove usr/share/emacs
+}
+
+sha512sums="
+81356239a92fb17885aa85a5192c84c2757ebb2e540920d0d41d07035795f08f4162f41b1a87bb2bfcf70ec61f19f1f158e4395a359f46b46f68cb9e24f259a8 desktop-file-utils-0.27.tar.xz
+"