aboutsummaryrefslogtreecommitdiffstats
path: root/community/devhelp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/devhelp/APKBUILD')
-rw-r--r--community/devhelp/APKBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/community/devhelp/APKBUILD b/community/devhelp/APKBUILD
index 602a7f00870..7fbb771e5e3 100644
--- a/community/devhelp/APKBUILD
+++ b/community/devhelp/APKBUILD
@@ -1,25 +1,33 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=devhelp
-pkgver=40.1
-pkgrel=0
+pkgver=43.0
+pkgrel=2
pkgdesc="API documentation browser for GTK+ and GNOME"
url="https://wiki.gnome.org/Apps/Devhelp"
-arch="all !mips64 !riscv64" # limited by webkit2gtk
+arch="all"
license="GPL-2.0-or-later"
depends="gsettings-desktop-schemas"
-makedepends="meson gobject-introspection-dev gsettings-desktop-schemas-dev
- webkit2gtk-dev amtk-dev glib-dev itstool"
+makedepends="
+ amtk-dev
+ appstream-glib
+ glib-dev
+ gobject-introspection-dev
+ gsettings-desktop-schemas-dev
+ itstool
+ meson
+ webkit2gtk-4.1-dev
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/devhelp/${pkgver%.*}/devhelp-$pkgver.tar.xz"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -27,5 +35,5 @@ package() {
}
sha512sums="
-4c541db9a2222dce4064f401c1d0a9f3233e2dbab17206358dfcce360286f69698248d08172fb236a692b125d8cd3a5bb76b6377b01b52c3d096fa4528400acd devhelp-40.1.tar.xz
+92f147659754480ac4aa02f21558572d4bb8a034251225d344a8cae16824d9c14071751dfca6439f98dc7f7884fb35ef2d9c708e42f11bb6b3dfd8648b784654 devhelp-43.0.tar.xz
"