aboutsummaryrefslogtreecommitdiffstats
path: root/community/dfrs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dfrs/APKBUILD')
-rw-r--r--community/dfrs/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/dfrs/APKBUILD b/community/dfrs/APKBUILD
index 7c034d5281d..78ad0d49d6a 100644
--- a/community/dfrs/APKBUILD
+++ b/community/dfrs/APKBUILD
@@ -2,10 +2,11 @@
# Maintainer: kpcyrd <git@rxv.cc>
pkgname=dfrs
pkgver=0.0.7
-pkgrel=0
+pkgrel=3
pkgdesc="Display file system space usage using graphs and colors"
url="https://github.com/anthraxx/dfrs"
-# s390x and riscv64 blocked by rust/cargo
+# s390x fails to build
+# riscv64: rust broken
arch="all !s390x !riscv64"
license="MIT"
makedepends="
@@ -20,6 +21,7 @@ subpackages="$pkgname-doc
options="net"
source="$pkgname-$pkgver.tar.gz::https://github.com/anthraxx/dfrs/archive/$pkgver.tar.gz"
+
build() {
make
}
@@ -34,7 +36,7 @@ package() {
install -Dm 644 "$builddir/target/completion/bash/dfrs" -t "$pkgdir/usr/share/bash-completion/completions"
install -Dm 644 "$builddir/target/completion/zsh/_dfrs" -t "$pkgdir/usr/share/zsh/site-functions"
- install -Dm 644 "$builddir/target/completion/fish/dfrs.fish" -t "$pkgdir/usr/share/fish/completions"
+ install -Dm 644 "$builddir/target/completion/fish/dfrs.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
}
sha512sums="8b8f67ff919e4f1012fe415b564574fe9b11caf01da90a025ca8b8c7707e3f90e865e30cfbeb24db7b80829d082ba7accce44e1897a67e39d129d94c171f21fe dfrs-0.0.7.tar.gz"