aboutsummaryrefslogtreecommitdiffstats
path: root/community/diffoscope/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/diffoscope/APKBUILD')
-rw-r--r--community/diffoscope/APKBUILD50
1 files changed, 39 insertions, 11 deletions
diff --git a/community/diffoscope/APKBUILD b/community/diffoscope/APKBUILD
index e2a9adc9ebb..cc968c1276b 100644
--- a/community/diffoscope/APKBUILD
+++ b/community/diffoscope/APKBUILD
@@ -1,31 +1,59 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=diffoscope
-pkgver=220
+pkgver=261
pkgrel=0
pkgdesc="In-depth comparison of files, archives, and directories"
url="https://diffoscope.org/"
arch="noarch"
license="GPL-3.0-or-later"
-makedepends="python3-dev py3-setuptools py3-docutils"
-depends="py3-magic py3-libarchive-c"
-checkdepends="py3-pytest gzip bzip2 unzip libarchive-tools cdrkit
- openssh-client-default"
-source="https://salsa.debian.org/reproducible-builds/diffoscope/-/archive/$pkgver/diffoscope-$pkgver.tar.gz
+depends="
+ py3-libarchive-c
+ py3-magic
"
+makedepends="
+ py3-docutils
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="
+ bzip2
+ cdrkit
+ gzip
+ libarchive-tools
+ openssh-client-default
+ py3-html2text
+ py3-pytest
+ py3-pytest-xdist
+ unzip
+ "
+subpackages="$pkgname-pyc"
+source="https://salsa.debian.org/reproducible-builds/diffoscope/-/archive/$pkgver/diffoscope-$pkgver.tar.gz"
+
+# secfixes:
+# 256-r0:
+# - CVE-2024-25711
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH=".:$PYTHONPATH" PYTHONDONTWRITEBYTECODE=1 py.test \
- -k 'not test_text_proper_indentation'
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # html test fails
+ PYTHONDONTWRITEBYTECODE=1 \
+ .testenv/bin/python3 -m pytest -n auto -k 'not test_diff'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-1be5b101a12756eff8d3b83dbe359af585ccfb336e9e3e65b3112b2b8b5ab93a58c250d1b91caaba78aaca88aa145321b7d45d3e710274bdfbedaedaa2aa1844 diffoscope-220.tar.gz
+32f3b8ad1410bb97a24b07169f6c12e9ab955b159a1e2cb9dcc3dbcb98207644f8bd45f21773dabb6dc2802148adccc35da0ccfc54b1967fc494d79a1940bf25 diffoscope-261.tar.gz
"