aboutsummaryrefslogtreecommitdiffstats
path: root/community/diffoscope/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/diffoscope/APKBUILD')
-rw-r--r--community/diffoscope/APKBUILD52
1 files changed, 40 insertions, 12 deletions
diff --git a/community/diffoscope/APKBUILD b/community/diffoscope/APKBUILD
index b46ef48ac90..0064fdb2f1f 100644
--- a/community/diffoscope/APKBUILD
+++ b/community/diffoscope/APKBUILD
@@ -1,31 +1,59 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=diffoscope
-pkgver=211
-pkgrel=0
+pkgver=263
+pkgrel=1
pkgdesc="In-depth comparison of files, archives, and directories"
url="https://diffoscope.org/"
arch="noarch"
license="GPL-3.0-or-later"
-makedepends="python3-dev py3-setuptools py3-docutils"
-depends="py3-magic py3-libarchive-c"
-checkdepends="py3-pytest gzip bzip2 unzip libarchive-tools cdrkit
- openssh-client-default"
-source="https://salsa.debian.org/reproducible-builds/diffoscope/-/archive/$pkgver/diffoscope-$pkgver.tar.gz
+depends="
+ py3-libarchive-c
+ py3-magic
"
+makedepends="
+ py3-docutils
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="
+ bzip2
+ cdrkit
+ gzip
+ libarchive-tools
+ openssh-client-default
+ py3-html2text
+ py3-pytest
+ py3-pytest-xdist
+ unzip
+ "
+subpackages="$pkgname-pyc"
+source="https://salsa.debian.org/reproducible-builds/diffoscope/-/archive/$pkgver/diffoscope-$pkgver.tar.gz"
+
+# secfixes:
+# 256-r0:
+# - CVE-2024-25711
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH=".:$PYTHONPATH" PYTHONDONTWRITEBYTECODE=1 py.test \
- -k 'not test_text_proper_indentation'
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # html test fails
+ PYTHONDONTWRITEBYTECODE=1 \
+ .testenv/bin/python3 -m pytest -n auto -k 'not test_diff'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-8409c867fa6d20959fab4e5e192989692c445e3d4031868ba5e68a92da57ffcc681c5fd2120b1e061d938059b65539295bd69e2677a133aee091e820b17e6250 diffoscope-211.tar.gz
+e5c3372d83006eb8691f78571de8f7b0c02aa97341cbcbd81e6eaa35f603ed8ca2d28ed826ef758ce32f691846ac7016e078d8a9d9e2649b8056c7c3ed84a4b6 diffoscope-263.tar.gz
"