aboutsummaryrefslogtreecommitdiffstats
path: root/community/dillo/openssl-1.1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/dillo/openssl-1.1.patch')
-rw-r--r--community/dillo/openssl-1.1.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/community/dillo/openssl-1.1.patch b/community/dillo/openssl-1.1.patch
deleted file mode 100644
index 79658e62435..00000000000
--- a/community/dillo/openssl-1.1.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Patch-Source: https://gitweb.gentoo.org/repo/gentoo.git/commit/www-client/dillo/files/dillo-3.0.5-openssl-1.1.patch?id=9489ea43e91dbe22e609e7029759defc6b7ffe8b
---- a/configure.ac
-+++ b/configure.ac
-@@ -286,7 +286,7 @@
-
- if test "x$ssl_ok" = "xyes"; then
- old_libs="$LIBS"
-- AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
-+ AC_CHECK_LIB(ssl, OPENSSL_config, ssl_ok=yes, ssl_ok=no, -lcrypto)
- LIBS="$old_libs"
- fi
-
---- a/dpi/https.c
-+++ b/dpi/https.c
-@@ -476,7 +476,11 @@
- case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
- /*Either self signed and untrusted*/
- /*Extract CN from certificate name information*/
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
-+#else
-+ if ((cn = strstr(X509_get_subject_name(remote_cert), "/CN=")) == NULL) {
-+#endif
- strcpy(buf, "(no CN given)");
- } else {
- char *cn_end;
-