aboutsummaryrefslogtreecommitdiffstats
path: root/community/directfb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/directfb/APKBUILD')
-rw-r--r--community/directfb/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/directfb/APKBUILD b/community/directfb/APKBUILD
index 0f5f69bc44a..9bc51c1e364 100644
--- a/community/directfb/APKBUILD
+++ b/community/directfb/APKBUILD
@@ -2,16 +2,16 @@
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=directfb
pkgver=1.7.7
-pkgrel=3
+pkgrel=8
pkgdesc="Library for hw graphics acceleration, input dev, windowing system on top of the Linux fb device"
arch="all"
-url="https://github.com/DirectFB/directfb"
+url="https://github.com/deniskropp/DirectFB"
license="LGPL-2.0-or-later"
makedepends="zlib-dev freetype-dev libdrm-dev libpng-dev perl tslib tslib-dev autoconf automake libtool"
subpackages="$pkgname-doc $pkgname-static $pkgname-dev"
builddir="$srcdir/DirectFB-$pkgver"
source="
- http://sources.webos-ports.org/DirectFB-$pkgver.tar.gz
+ https://dev.alpinelinux.org/archive/directfb/DirectFB-$pkgver.tar.gz
0001-directfb-fix-musl-compile.patch
0002-Fix-musl-PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP-comp.patch
0003-remove-set-gamma-ramp.patch
@@ -20,6 +20,7 @@ source="
0006-fix-client-gfx_state-initialisation.patch
0007-tslib-Automatically-detect-touchscreens-using-ts_setup.patch
0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
+ fix-missing-basename.patch
"
prepare() {
@@ -55,7 +56,8 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c9ce8ffe7d7d17b0351da6a031db7345f31fb7112545f9352834ad33225a93e6284ef0e576ef5fc595bc9060c1756051322fa20f7b5b3444b68d7f05bd1ba494 DirectFB-1.7.7.tar.gz
+sha512sums="
+c9ce8ffe7d7d17b0351da6a031db7345f31fb7112545f9352834ad33225a93e6284ef0e576ef5fc595bc9060c1756051322fa20f7b5b3444b68d7f05bd1ba494 DirectFB-1.7.7.tar.gz
d9325c228a534d2d2b93b4dacf896fc12c703b9e08adf1ae8f5baea2a0ed5c4d07d56b8bc63dc605362f093624eab40686b43028ef15a78a01bc10e5f41c16bc 0001-directfb-fix-musl-compile.patch
ed3bf9bf76616174aca6ae92fd9873c9452951b8a2acb60e1ccbbea0c4a7c9766e510899bc8f58c24dd5888c1e7e1f0a0d4a823f0bd9e03a4c9d2a54fb714221 0002-Fix-musl-PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP-comp.patch
bd1d0738c48411e8e065b8a250c1b31334ac65b26a8f6c91d5ad167a4d8fdac1de862c05940567e48fc740dd45fbecf906ebdfbff63420d4f86bee7a3a0746ee 0003-remove-set-gamma-ramp.patch
@@ -63,4 +65,6 @@ d68002702f3521a71405bb403b874dced5b123a2de037c9eb05667123a578c0e9a9f13a822fd8d77
c768ca7a4dae7fc0cd7d4fa559ab74adb6b5f21245e0f9b5d56af15b20effc04e6739e86d52d65c902c5e76ad72e966cd9db68f57a9bad11a004525825d443a4 0005-fix-tslib-configure.patch
6b118928c2ebe58654e1bf32433b084f4dc150526eec1b53f9eb4b856aee25733bd8d6114fde973fcb64416e4146f458cdb75e5836d7507cf802b84e44544462 0006-fix-client-gfx_state-initialisation.patch
43000c629eb24bd6b88d284dc010ea5a2a3facbf9498ab752127c25a890fd52b9a29a09d46264befea9fef19dcfe6f24d6cefa103a68d4c2ab185b6142a5c1b9 0007-tslib-Automatically-detect-touchscreens-using-ts_setup.patch
-a21470281e7886ee37b0c1e49498e250a890894cee8ab6c5d46f563cd75c132d112d993e047ca0649b7cd545f07b5a6476e7027e56bcc9bd2350d282f01f71b3 0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch"
+a21470281e7886ee37b0c1e49498e250a890894cee8ab6c5d46f563cd75c132d112d993e047ca0649b7cd545f07b5a6476e7027e56bcc9bd2350d282f01f71b3 0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
+210b29a79b12302071e15b6554b4c117efc4329d17ed82319c22c0f6c0f95395ec246de6e6f2878ae6e3a82d807cf5ce118660d1f19bc8e8619d7e192fca0cb3 fix-missing-basename.patch
+"