aboutsummaryrefslogtreecommitdiffstats
path: root/community/dnsrecon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dnsrecon/APKBUILD')
-rw-r--r--community/dnsrecon/APKBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/community/dnsrecon/APKBUILD b/community/dnsrecon/APKBUILD
index 017a2608e42..81d062c7c37 100644
--- a/community/dnsrecon/APKBUILD
+++ b/community/dnsrecon/APKBUILD
@@ -1,34 +1,41 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=dnsrecon
-pkgver=1.1.1
-pkgrel=0
+pkgver=1.1.5
+pkgrel=2
pkgdesc="DNS Enumeration Script"
url="https://github.com/darkoperator/dnsrecon"
arch="noarch"
license="GPL-2.0-only"
-depends="py3-dnspython py3-lxml py3-netaddr"
-makedepends="py3-build py3-installer py3-poetry-core
-py3-wheel py3-setuptools"
+depends="py3-dnspython py3-lxml py3-netaddr py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-wheel
+ "
checkdepends="py3-pytest"
options="!check"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/darkoperator/dnsrecon/archive/$pkgver.tar.gz"
build() {
- python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m installer -d testenv dist/$pkgname-$pkgver-py3-none-any.whl
- local sitedir="$(python3 -c 'import site;print(site.getsitepackages()[0])')"
-
- PYTHONPATH="$PWD/testenv/$sitedir" python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 -m installer -d "$pkgdir" dist/$pkgname-$pkgver-py3-none-any.whl
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-985fcbd2874f72144e3d0b52ee322df848abfb1fecd403d6a9786cfa5509610609d9aacb4ffc2fa89b5717c21942fa81d1884ddbfa0cb605e95fa1e0da1a2b57 dnsrecon-1.1.1.tar.gz
+c28d8865b336ac09ab4229f858cd4c1b0a248408f4f60a86e0976475c5bbb86f8d1185e08c288cad0977b777b42c7cf0d8da468a985317a2fe23cc6ca81fbff0 dnsrecon-1.1.5.tar.gz
"