aboutsummaryrefslogtreecommitdiffstats
path: root/community/dnsrecon/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dnsrecon/APKBUILD')
-rw-r--r--community/dnsrecon/APKBUILD39
1 files changed, 28 insertions, 11 deletions
diff --git a/community/dnsrecon/APKBUILD b/community/dnsrecon/APKBUILD
index 5dcd9d470a0..81d062c7c37 100644
--- a/community/dnsrecon/APKBUILD
+++ b/community/dnsrecon/APKBUILD
@@ -1,24 +1,41 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=dnsrecon
-pkgver=0.10.1
-pkgrel=0
+pkgver=1.1.5
+pkgrel=2
pkgdesc="DNS Enumeration Script"
url="https://github.com/darkoperator/dnsrecon"
arch="noarch"
license="GPL-2.0-only"
-depends="py3-dnspython py3-lxml py3-netaddr"
+depends="py3-dnspython py3-lxml py3-netaddr py3-setuptools"
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-pytest"
options="!check"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/darkoperator/dnsrecon/archive/$pkgver.tar.gz"
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
+}
+
package() {
- mkdir -p "$pkgdir"/usr/share/dnsrecon
- cp -r lib msf_plugin tools "$pkgdir"/usr/share/dnsrecon
- install -D -m 0755 dnsrecon.py "$pkgdir"/usr/share/dnsrecon/dnsrecon.py
- mkdir -p "$pkgdir"/usr/bin
- ln -sf /usr/share/dnsrecon/dnsrecon.py "$pkgdir"/usr/bin/dnsrecon
- install -D -m 0644 namelist.txt subdomains-*.txt -t \
- "$pkgdir"/usr/share/dnsrecon/
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="ed25fedd9f2c7adf5d1091bbf8060cdb0d0f74ef26134ffe7a482459bbab7dcb0b2c2da631bddf7f9ef9ec7d08d44c91fba531ba5fa0c4bf3567bbb02348ec5f dnsrecon-0.10.1.tar.gz"
+sha512sums="
+c28d8865b336ac09ab4229f858cd4c1b0a248408f4f60a86e0976475c5bbb86f8d1185e08c288cad0977b777b42c7cf0d8da468a985317a2fe23cc6ca81fbff0 dnsrecon-1.1.5.tar.gz
+"