aboutsummaryrefslogtreecommitdiffstats
path: root/community/dnstwist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dnstwist/APKBUILD')
-rw-r--r--community/dnstwist/APKBUILD35
1 files changed, 26 insertions, 9 deletions
diff --git a/community/dnstwist/APKBUILD b/community/dnstwist/APKBUILD
index 4db33afa430..757f787ce92 100644
--- a/community/dnstwist/APKBUILD
+++ b/community/dnstwist/APKBUILD
@@ -1,21 +1,35 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=dnstwist
-pkgver=20201228
-pkgrel=1
+pkgver=20240116
+pkgrel=0
pkgdesc="Domain name permutation engine"
options="!check" # no testsuite
-url="dnstwist.it"
+url="https://dnstwist.it"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-requests py3-dnspython py3-tld"
-makedepends="py3-setuptools"
-subpackages="$pkgname-dictionaries"
+depends="
+ py3-dnspython
+ py3-geoip2
+ py3-idna
+ py3-requests
+ py3-tld
+ py3-whois
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-dictionaries $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/elceef/dnstwist/archive/$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -23,7 +37,8 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
dictionaries() {
@@ -36,4 +51,6 @@ dictionaries() {
done
}
-sha512sums="98735f9ac145f54c0c965786052942d00c9c658490df5e9c079a2baae135a516fc079b8bc3ace68f18a529685008eee0e6a098bea38196aedbdd2e2d1557dca6 dnstwist-20201228.tar.gz"
+sha512sums="
+3eaee43ddb0a17dc81956252bdd46403c822c55f63a59ccb0cc9e2eeb0e41158919a1571d0dc5335884399254e2eabc902bfe616051d7089a6c917a102927c09 dnstwist-20240116.tar.gz
+"