aboutsummaryrefslogtreecommitdiffstats
path: root/community/dnstwist/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dnstwist/APKBUILD')
-rw-r--r--community/dnstwist/APKBUILD38
1 files changed, 27 insertions, 11 deletions
diff --git a/community/dnstwist/APKBUILD b/community/dnstwist/APKBUILD
index a1135866d1f..95bf517850c 100644
--- a/community/dnstwist/APKBUILD
+++ b/community/dnstwist/APKBUILD
@@ -1,29 +1,45 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=dnstwist
-pkgver=20220131
-pkgrel=1
+pkgver=20240116
+pkgrel=2
pkgdesc="Domain name permutation engine"
-options="!check" # no testsuite
url="https://dnstwist.it"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-requests py3-dnspython py3-tld"
-makedepends="py3-setuptools"
-subpackages="$pkgname-dictionaries"
-
+depends="
+ py3-dnspython
+ py3-geoip2
+ py3-idna
+ py3-requests
+ py3-tld
+ py3-whois
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-dictionaries $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/elceef/dnstwist/archive/$pkgver.tar.gz"
+options="!check" # no testsuite
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
dictionaries() {
@@ -37,5 +53,5 @@ dictionaries() {
}
sha512sums="
-fa0d4636e081814bd5e376c349377fbca780afc78e7a97226a14cb86c8be8bd6e1c0681f006fc8cf14625ff8962e5dd7d27bf1162f699c7d135740a48d155a52 dnstwist-20220131.tar.gz
+3eaee43ddb0a17dc81956252bdd46403c822c55f63a59ccb0cc9e2eeb0e41158919a1571d0dc5335884399254e2eabc902bfe616051d7089a6c917a102927c09 dnstwist-20240116.tar.gz
"