aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin-plugins/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dolphin-plugins/APKBUILD')
-rw-r--r--community/dolphin-plugins/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/dolphin-plugins/APKBUILD b/community/dolphin-plugins/APKBUILD
index b3f2fe4af38..511caa20f5c 100644
--- a/community/dolphin-plugins/APKBUILD
+++ b/community/dolphin-plugins/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=dolphin-plugins
-pkgver=22.04.3
+pkgver=24.02.2
pkgrel=0
-url="https://www.kde.org/applications/system/dolphin/"
pkgdesc="Extra Dolphin plugins"
+url="https://www.kde.org/applications/system/dolphin/"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
license="GPL-2.0-or-later"
makedepends="
dolphin-dev
@@ -17,11 +19,12 @@ makedepends="
ktexteditor-dev
ktextwidgets-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-plugins-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/sdk/dolphin-plugins.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-plugins-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -33,8 +36,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +44,5 @@ package() {
}
sha512sums="
-1b96511fbf8ec93b03a5f204c2e4cff232ca0d09e4d1599c89d4d514deb3fb889dfd3050a5cabe4e35b6e65a5283ad09635a13931c8484eebc98a22ba9057b42 dolphin-plugins-22.04.3.tar.xz
+585249422ef1637c2caee044a71d11c621127ef578131d2323e879b12bee2f17082c4811273e6bb0013d1386f7010ded187627965bfce0b1b412b25048cd11d8 dolphin-plugins-24.02.2.tar.xz
"