aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin-plugins/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dolphin-plugins/APKBUILD')
-rw-r--r--community/dolphin-plugins/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/dolphin-plugins/APKBUILD b/community/dolphin-plugins/APKBUILD
index e9da141440e..511caa20f5c 100644
--- a/community/dolphin-plugins/APKBUILD
+++ b/community/dolphin-plugins/APKBUILD
@@ -1,11 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=dolphin-plugins
-pkgver=21.04.2
+pkgver=24.02.2
pkgrel=0
-arch="all !armhf !s390x !mips64"
-url="https://www.kde.org/applications/system/dolphin/"
pkgdesc="Extra Dolphin plugins"
+url="https://www.kde.org/applications/system/dolphin/"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="GPL-2.0-or-later"
makedepends="
dolphin-dev
@@ -15,14 +19,16 @@ makedepends="
ktexteditor-dev
ktextwidgets-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-plugins-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/sdk/dolphin-plugins.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-plugins-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_svn=OFF # Broken "error: expected unqualified-id before '(' token"
@@ -30,14 +36,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-379e87f0ee28dd414c1ffe1f2e7775681cf639cda72a6357c357f2a7a30aefee77cfc8b52cb4030ff68555a38d0abf428ac155cbd2d3263ac55b4f41b9ae1fda dolphin-plugins-21.04.2.tar.xz
+585249422ef1637c2caee044a71d11c621127ef578131d2323e879b12bee2f17082c4811273e6bb0013d1386f7010ded187627965bfce0b1b412b25048cd11d8 dolphin-plugins-24.02.2.tar.xz
"