aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin-plugins/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dolphin-plugins/APKBUILD')
-rw-r--r--community/dolphin-plugins/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/dolphin-plugins/APKBUILD b/community/dolphin-plugins/APKBUILD
index 00569e228a3..511caa20f5c 100644
--- a/community/dolphin-plugins/APKBUILD
+++ b/community/dolphin-plugins/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=dolphin-plugins
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
-url="https://www.kde.org/applications/system/dolphin/"
pkgdesc="Extra Dolphin plugins"
+url="https://www.kde.org/applications/system/dolphin/"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
license="GPL-2.0-or-later"
makedepends="
dolphin-dev
@@ -17,14 +19,16 @@ makedepends="
ktexteditor-dev
ktextwidgets-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-plugins-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/sdk/dolphin-plugins.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-plugins-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_svn=OFF # Broken "error: expected unqualified-id before '(' token"
@@ -32,8 +36,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -41,5 +44,5 @@ package() {
}
sha512sums="
-2fb7fbd6490d768f3eb7d756429d858337b8088a7c87836ed4a54fc3f863f50c4973bbe2ae149d53d2769d7ce3c31fbd737bc4afc74fd14260a158da83992076 dolphin-plugins-21.08.3.tar.xz
+585249422ef1637c2caee044a71d11c621127ef578131d2323e879b12bee2f17082c4811273e6bb0013d1386f7010ded187627965bfce0b1b412b25048cd11d8 dolphin-plugins-24.02.2.tar.xz
"