aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dolphin/APKBUILD')
-rw-r--r--community/dolphin/APKBUILD38
1 files changed, 23 insertions, 15 deletions
diff --git a/community/dolphin/APKBUILD b/community/dolphin/APKBUILD
index a6c68627e1f..3aa3af1d9aa 100644
--- a/community/dolphin/APKBUILD
+++ b/community/dolphin/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=dolphin
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/dolphin"
pkgdesc="KDE File Manager"
license="GPL-2.0-only"
@@ -16,7 +18,6 @@ depends="
depends_dev="
baloo-dev
baloo-widgets-dev
- kactivities-dev
kbookmarks-dev
kcmutils-dev
kcompletion-dev
@@ -28,27 +29,35 @@ depends_dev="
kfilemetadata-dev
ki18n-dev
kiconthemes-dev
- kinit-dev
kio-dev
knewstuff-dev
knotifications-dev
kparts-dev
ktextwidgets-dev
+ kuserfeedback-dev
kwindowsystem-dev
+ musl-fts-dev
phonon-dev
- qt5-qtbase-dev
+ plasma-activities-dev
+ qt6-qtbase-dev
solid-dev
"
-makedepends="$depends_dev extra-cmake-modules ruby-test-unit"
+makedepends="$depends_dev
+ extra-cmake-modules
+ ruby-test-unit
+ samurai
+ "
checkdepends="
- xvfb-run
dbus
+ xvfb-run
"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-zsh-completion"
+_repo_url="https://invent.kde.org/system/dolphin.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
+ LDFLAGS="$LDFLAGS -Wl,-z,stack-size=0x100000" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -56,9 +65,8 @@ build() {
}
check() {
- cd build
- # kfileitemmodeltest, placesitemmodeltest and dolphinmainwindowtest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(kfileitemmodel|placesitemmodel|dolphinmainwindow)test"
+ # kfileitemmodeltest, dolphinquerytest and dolphinmainwindowtest are broken
+ xvfb-run -a ctest --test-dir build --output-on-failure -E "(kfileitemmodel|dolphinquery|dolphinmainwindow)test"
}
package() {
@@ -69,5 +77,5 @@ package() {
}
sha512sums="
-bb7d2f342aecae3b424aef93591124a5ca041e5e75909ed43c6202bc7cf7ab0e34a883050194b6e71f71425b2116ee579e67016205a648de6d5e5b0d01bf3ea8 dolphin-21.04.3.tar.xz
+951aa3a29003f3d14cfed4b3b8da000e4c8cb4b71172f32b145d36cde99713f08475d782225743fd7f27a25976b5136f241e6cad5f5c4b0eeffd4345f1b3d7df dolphin-24.02.2.tar.xz
"