aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dolphin/APKBUILD')
-rw-r--r--community/dolphin/APKBUILD92
1 files changed, 63 insertions, 29 deletions
diff --git a/community/dolphin/APKBUILD b/community/dolphin/APKBUILD
index 8f1202efbaa..3aa3af1d9aa 100644
--- a/community/dolphin/APKBUILD
+++ b/community/dolphin/APKBUILD
@@ -1,47 +1,81 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=dolphin
-pkgver=19.12.0
-pkgrel=1
-arch="all"
+pkgver=24.02.2
+pkgrel=0
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://kde.org/applications/system/dolphin"
pkgdesc="KDE File Manager"
license="GPL-2.0-only"
-depends="udisks2"
-depends_dev="qt5-qtbase-dev kdoctools-dev kinit-dev kcmutils-dev knewstuff-dev
- kcoreaddons-dev ki18n-dev kdbusaddons-dev kbookmarks-dev kconfig-dev
- kio-dev kparts-dev solid-dev kiconthemes-dev kcompletion-dev
- ktextwidgets-dev knotifications-dev kcrash-dev kwindowsystem-dev
- phonon-dev baloo-dev baloo-widgets-dev kfilemetadata-dev kactivities-dev"
-makedepends="$depends_dev extra-cmake-modules ruby-test-unit"
-checkdepends="xvfb-run dbus"
+depends="
+ udisks2
+ kio-extras
+ "
+depends_dev="
+ baloo-dev
+ baloo-widgets-dev
+ kbookmarks-dev
+ kcmutils-dev
+ kcompletion-dev
+ kconfig-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kfilemetadata-dev
+ ki18n-dev
+ kiconthemes-dev
+ kio-dev
+ knewstuff-dev
+ knotifications-dev
+ kparts-dev
+ ktextwidgets-dev
+ kuserfeedback-dev
+ kwindowsystem-dev
+ musl-fts-dev
+ phonon-dev
+ plasma-activities-dev
+ qt6-qtbase-dev
+ solid-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ ruby-test-unit
+ samurai
+ "
+checkdepends="
+ dbus
+ xvfb-run
+ "
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-zsh-completion"
+_repo_url="https://invent.kde.org/system/dolphin.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
build() {
- cd "$builddir"/build
- cmake "$builddir" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ LDFLAGS="$LDFLAGS -Wl,-z,stack-size=0x100000" \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ cmake --build build
}
check() {
- cd "$builddir"/build
- # kfileitemmodeltest and placesitemmodeltest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(kfileitemmodel|placesitemmodel)test"
+ # kfileitemmodeltest, dolphinquerytest and dolphinmainwindowtest are broken
+ xvfb-run -a ctest --test-dir build --output-on-failure -E "(kfileitemmodel|dolphinquery|dolphinmainwindow)test"
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
+
+ # We don't ship systemd
+ rm -r "$pkgdir"/usr/lib/systemd
}
-sha512sums="e9f47d8ed9e5b3def97182d9d1600730aa41e69d32aaf49b705fe2542eeda93ec719624e735e5f7d36a1dbf64c58e2a7f177e3ac4daf303ad5a2ba519d03923e dolphin-19.12.0.tar.xz"
+sha512sums="
+951aa3a29003f3d14cfed4b3b8da000e4c8cb4b71172f32b145d36cde99713f08475d782225743fd7f27a25976b5136f241e6cad5f5c4b0eeffd4345f1b3d7df dolphin-24.02.2.tar.xz
+"