aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dolphin/APKBUILD')
-rw-r--r--community/dolphin/APKBUILD38
1 files changed, 23 insertions, 15 deletions
diff --git a/community/dolphin/APKBUILD b/community/dolphin/APKBUILD
index a97eaef1f4a..81928e47e5e 100644
--- a/community/dolphin/APKBUILD
+++ b/community/dolphin/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=dolphin
-pkgver=21.08.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/dolphin"
pkgdesc="KDE File Manager"
license="GPL-2.0-only"
@@ -16,7 +18,6 @@ depends="
depends_dev="
baloo-dev
baloo-widgets-dev
- kactivities-dev
kbookmarks-dev
kcmutils-dev
kcompletion-dev
@@ -28,27 +29,35 @@ depends_dev="
kfilemetadata-dev
ki18n-dev
kiconthemes-dev
- kinit-dev
kio-dev
knewstuff-dev
knotifications-dev
kparts-dev
ktextwidgets-dev
+ kuserfeedback-dev
kwindowsystem-dev
+ musl-fts-dev
phonon-dev
- qt5-qtbase-dev
+ plasma-activities-dev
+ qt6-qtbase-dev
solid-dev
"
-makedepends="$depends_dev extra-cmake-modules ruby-test-unit"
+makedepends="$depends_dev
+ extra-cmake-modules
+ ruby-test-unit
+ samurai
+ "
checkdepends="
- xvfb-run
dbus
+ xvfb-run
"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-zsh-completion"
+_repo_url="https://invent.kde.org/system/dolphin.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
+ LDFLAGS="$LDFLAGS -Wl,-z,stack-size=0x100000" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -56,9 +65,8 @@ build() {
}
check() {
- cd build
- # kfileitemmodeltest, placesitemmodeltest and dolphinmainwindowtest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(kfileitemmodel|placesitemmodel|dolphinmainwindow)test"
+ # kfileitemmodeltest, dolphinquerytest and dolphinmainwindowtest are broken
+ xvfb-run -a ctest --test-dir build --output-on-failure -E "(kfileitemmodel|dolphinquery|dolphinmainwindow)test"
}
package() {
@@ -69,5 +77,5 @@ package() {
}
sha512sums="
-20a9e03bbea96c4850be51e1cbaa7fd8e0d93f74c682ca3d4534ddef44338f023a0ca0ec618a97cd8171a30401e04e5991fad1d055d4ec8b91935027c2ebf26b dolphin-21.08.2.tar.xz
+cd572d93dc1d1e762980f48c60cdac6aca2abe3cccad4cf1e67efc5ea9682e03d10f32e861429e002446d2627a0f0d06e855d8db9bbd43e0410a34db30a5de39 dolphin-24.02.1.tar.xz
"