aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dolphin/APKBUILD')
-rw-r--r--community/dolphin/APKBUILD78
1 files changed, 60 insertions, 18 deletions
diff --git a/community/dolphin/APKBUILD b/community/dolphin/APKBUILD
index a530d2676b9..81928e47e5e 100644
--- a/community/dolphin/APKBUILD
+++ b/community/dolphin/APKBUILD
@@ -1,25 +1,63 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=dolphin
-pkgver=20.08.2
+pkgver=24.02.1
pkgrel=0
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://kde.org/applications/system/dolphin"
pkgdesc="KDE File Manager"
license="GPL-2.0-only"
-depends="udisks2 kio-extras"
-depends_dev="qt5-qtbase-dev kdoctools-dev kinit-dev kcmutils-dev knewstuff-dev
- kcoreaddons-dev ki18n-dev kdbusaddons-dev kbookmarks-dev kconfig-dev
- kio-dev kparts-dev solid-dev kiconthemes-dev kcompletion-dev
- ktextwidgets-dev knotifications-dev kcrash-dev kwindowsystem-dev
- phonon-dev baloo-dev baloo-widgets-dev kfilemetadata-dev kactivities-dev"
-makedepends="$depends_dev extra-cmake-modules ruby-test-unit"
-checkdepends="xvfb-run dbus"
+depends="
+ udisks2
+ kio-extras
+ "
+depends_dev="
+ baloo-dev
+ baloo-widgets-dev
+ kbookmarks-dev
+ kcmutils-dev
+ kcompletion-dev
+ kconfig-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdoctools-dev
+ kfilemetadata-dev
+ ki18n-dev
+ kiconthemes-dev
+ kio-dev
+ knewstuff-dev
+ knotifications-dev
+ kparts-dev
+ ktextwidgets-dev
+ kuserfeedback-dev
+ kwindowsystem-dev
+ musl-fts-dev
+ phonon-dev
+ plasma-activities-dev
+ qt6-qtbase-dev
+ solid-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
+ ruby-test-unit
+ samurai
+ "
+checkdepends="
+ dbus
+ xvfb-run
+ "
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-zsh-completion"
+_repo_url="https://invent.kde.org/system/dolphin.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/dolphin-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
+ LDFLAGS="$LDFLAGS -Wl,-z,stack-size=0x100000" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -27,13 +65,17 @@ build() {
}
check() {
- cd build
- # kfileitemmodeltest, placesitemmodeltest and dolphinmainwindowtest are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(kfileitemmodel|placesitemmodel|dolphinmainwindow)test"
+ # kfileitemmodeltest, dolphinquerytest and dolphinmainwindowtest are broken
+ xvfb-run -a ctest --test-dir build --output-on-failure -E "(kfileitemmodel|dolphinquery|dolphinmainwindow)test"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
+
+ # We don't ship systemd
+ rm -r "$pkgdir"/usr/lib/systemd
}
-sha512sums="f64000957a1b10ff9e2783af9b32cf184989bf000c33ee7ed47026cb26014770a5b889f9c10c11c833b2310ca1e72086e8f55eb78e650fbe82067b1f1fafee19 dolphin-20.08.2.tar.xz"
+sha512sums="
+cd572d93dc1d1e762980f48c60cdac6aca2abe3cccad4cf1e67efc5ea9682e03d10f32e861429e002446d2627a0f0d06e855d8db9bbd43e0410a34db30a5de39 dolphin-24.02.1.tar.xz
+"