aboutsummaryrefslogtreecommitdiffstats
path: root/community/dos2unix/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dos2unix/APKBUILD')
-rw-r--r--community/dos2unix/APKBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/community/dos2unix/APKBUILD b/community/dos2unix/APKBUILD
index 6dbaae5b8c7..6183df92f8f 100644
--- a/community/dos2unix/APKBUILD
+++ b/community/dos2unix/APKBUILD
@@ -1,31 +1,22 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=dos2unix
-pkgver=7.4.2
+pkgver=7.5.2
pkgrel=0
pkgdesc="Text file format converters"
-url="http://waterlan.home.xs4all.nl/dos2unix.html"
+url="https://waterlan.home.xs4all.nl/dos2unix.html"
arch="all"
license="BSD-2-Clause"
checkdepends="gettext-dev perl-utils"
subpackages="$pkgname-doc"
-source="http://waterlan.home.xs4all.nl/dos2unix/dos2unix-$pkgver.tar.gz"
-
-prepare() {
- default_prepare
- sed -e '/^LDFLAGS/s|=|+=|' \
- -e '/CFLAGS_OS \+=/d' \
- -e '/LDFLAGS_EXTRA \+=/d' \
- -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
- -i Makefile
-}
+source="https://waterlan.home.xs4all.nl/dos2unix/dos2unix-$pkgver.tar.gz"
build() {
- make ENABLE_NLS= -C "$builddir"
+ make ENABLE_NLS= LDFLAGS_USER="$LDFLAGS"
}
check() {
- make check -C "$builddir"
+ make check
}
package() {
@@ -33,7 +24,9 @@ package() {
docsubdir=$pkgname \
ENABLE_NLS= \
DESTDIR="$pkgdir" \
- -C "$builddir" install
+ install
}
-sha512sums="3fb77561596bafd83f3f7807ce967e58d5a96e5235afe3a4074ae7112297445690b2586bf652eb0b5bd1984fd41a79478355f6df8244561b4167a8a09593110d dos2unix-7.4.2.tar.gz"
+sha512sums="
+d76d799435dd248850f72cc50af2144a51e99f04ea83a1447c4edd828625c83f0afba367da51aa83defced4cbf34f3b75387a0821010f7b212225571036efbb2 dos2unix-7.5.2.tar.gz
+"