aboutsummaryrefslogtreecommitdiffstats
path: root/community/dotnet6-runtime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dotnet6-runtime/APKBUILD')
-rw-r--r--community/dotnet6-runtime/APKBUILD95
1 files changed, 73 insertions, 22 deletions
diff --git a/community/dotnet6-runtime/APKBUILD b/community/dotnet6-runtime/APKBUILD
index 5f566c192d9..3a6acaf6706 100644
--- a/community/dotnet6-runtime/APKBUILD
+++ b/community/dotnet6-runtime/APKBUILD
@@ -1,24 +1,16 @@
-# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
# Contributor: Antoine Martin (ayakael) <dev@ayakael.net>
-
-#
-# Variables for dotnet build version 6.0
-# This APKBUILD is designed to be the same for version 6.0 and up
-# except for the variables in this first section
-#
-
+# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
pkgname=dotnet6-runtime
-pkgver=6.0.6
-_bldver=6.0.106-r0
+pkgver=6.0.29
+_bldver=6.0.129-r0
pkgrel=0
-# Following for dotnet build version 6.0 and up
_pkgver_macro=${pkgver%.*}
_pkgver_name=${_pkgver_macro//[.0]}
_bldver_ver=${_bldver%%-*}
pkgdesc="The .NET $_pkgver_macro Core runtime"
arch="x86_64 aarch64 armv7"
-url=https://www.microsoft.com/net/core
+url="https://dotnet.microsoft.com/"
license="MIT"
depends="
dotnet$_pkgver_name-hostfxr
@@ -38,18 +30,77 @@ provides="dotnet$_pkgver_name=$pkgver-r$pkgrel"
options="!check" # No test suite
source="dotnet.sh.in"
builddir="$srcdir"
+
+# secfixes:
+# 6.0.6-r0:
+# - CVE-2022-30184
+# 6.0.8-r0:
+# - CVE-2022-34716
+# 6.0.9-r0:
+# - CVE-2022-38013
+# 6.0.10-r0:
+# - CVE-2022-41032
+# 6.0.12-r0:
+# - CVE-2022-41089
+# 6.0.13-r0:
+# - CVE-2023-21538
+# 6.0.14-r0:
+# - CVE-2023-21808
+# 6.0.16-r0:
+# - CVE-2023-28260
+# 6.0.18-r0:
+# - CVE-2023-24895
+# - CVE-2023-24897
+# - CVE-2023-24936
+# - CVE-2023-29331
+# - CVE-2023-29337
+# - CVE-2023-33126
+# - CVE-2023-33128
+# - CVE-2023-33135
+# 6.0.20-r0:
+# - CVE-2023-33127
+# - CVE-2023-33170
+# 6.0.21-r0:
+# - CVE-2023-35390
+# - CVE-2023-38180
+# - CVE-2023-35391
+# 6.0.22-r0:
+# - CVE-2023-36792
+# - CVE-2023-36793
+# - CVE-2023-36794
+# - CVE-2023-36796
+# - CVE-2023-36799
+# 6.0.23-r0:
+# - CVE-2023-44487
+# 6.0.24-r0:
+# - CVE-2023-36792
+# - CVE-2023-36793
+# - CVE-2023-36794
+# - CVE-2023-36796
+# - CVE-2023-36799
+# - CVE-2023-44487
+# 6.0.25-r0:
+# - CVE-2023-36049
+# - CVE-2023-36558
+# 6.0.26-r0:
+# - CVE-2024-0056
+# - CVE-2024-0057
+# - CVE-2024-21319
+# 6.0.27-r0:
+# - CVE-2024-21386
+# - CVE-2024-21404
+# 6.0.29-r0:
+# - CVE-2024-21409
+
_libdir="/usr/lib"
-# custom function that converts Alpine arch syntax to dotnet arch syntax
-_get_arch() {
- case $1 in
- x86_64) local arch=x64;;
- aarch64) local arch=arm64;;
- armv7|armhf) local arch=arm;;
- esac
- echo $arch
-}
-_dotnet_arch=$(_get_arch $CARCH)
+case $CARCH in
+ x86_64) _dotnet_arch="x64";;
+ aarch64) _dotnet_arch="arm64";;
+ armv7) _dotnet_arch="arm";;
+ armhf) _dotnet_arch="armv6";;
+ *) _dotnet_arch="$CARCH";;
+esac
build() {
sed "s|%LIBDIR%|$_libdir/dotnet|" "$srcdir"/dotnet.sh.in > "$srcdir"/dotnet.sh