aboutsummaryrefslogtreecommitdiffstats
path: root/community/dsme/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/dsme/APKBUILD')
-rw-r--r--community/dsme/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/dsme/APKBUILD b/community/dsme/APKBUILD
index 4eaabf50f6e..6d15fc0d9dd 100644
--- a/community/dsme/APKBUILD
+++ b/community/dsme/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=dsme
-pkgver=0.83.0
-pkgrel=0
+pkgver=0.84.0
+pkgrel=3
_commit_dbusglib="d42176ae4763e5288ef37ea314fe58387faf2005"
pkgdesc="Device State Management Entity"
-url="https://git.sailfishos.org/mer-core/dsme/"
+url="https://github.com/sailfishos/dsme"
arch="all"
license="LGPL-2.1-only"
depends_dev="
@@ -19,7 +19,7 @@ makedepends="$depends_dev
libtool
"
subpackages="$pkgname-dev $pkgname-openrc"
-source="https://git.sailfishos.org/mer-core/dsme/-/archive/$pkgver/dsme-$pkgver.tar.gz
+source="https://github.com/sailfishos/dsme/archive/$pkgver/dsme-$pkgver.tar.gz
https://github.com/sailfishos-mirror/dbus-glib/archive/$_commit_dbusglib/dbus-glib-$_commit_dbusglib.tar.gz
0001-correct-paths.patch
0002-disable-werror.patch
@@ -51,7 +51,8 @@ build() {
--disable-upstart \
--disable-validatorlistener \
--enable-pwrkeymonitor \
- --enable-abootsettings
+ --enable-abootsettings \
+ --enable-usewheel
make
}
@@ -64,10 +65,13 @@ package() {
# Remove installed tests
rm -r "$pkgdir"/opt
+
+ mkdir -p "$pkgdir"/usr/share/dbus-1/system.d/
+ mv "$pkgdir"/etc/dbus-1/system.d/* "$pkgdir"/usr/share/dbus-1/system.d/
}
sha512sums="
-46c829206ff4971541b74af71d4491c1148423595275a705220d656e3fb3522baeab1f883af3f3f5e8e584aaf4d10d0ea92ddc8fa298220bdd036018508ecfdd dsme-0.83.0.tar.gz
+239dedeb0cecd0c6168a9702f6076283ed27d25bbbffbae6004949f580c2293ca1d0e59417562574bd1240f6587e02daf845bf478e65622d6df8fab8c07e8876 dsme-0.84.0.tar.gz
665cd6395ee0ea14086ba30188c62a72697b3f63484681e18fc7f54109c9aca162f2e33aa2fa4d45287c6c0b590e81ca310c143dac0232cd5887692cdaf51256 dbus-glib-d42176ae4763e5288ef37ea314fe58387faf2005.tar.gz
063ce9f2bd13fb2bd05ab9cd11544265eb5378562ee1fbed1cfa65d2345d092cfcff69f57589d3914005c31a00a58f3993cc13b59615ebe0f48458ba478d8772 0001-correct-paths.patch
2b18c6affaefa786358c07480968fd744370c48452c05e969cc8b26cba5307279ce51f782f42778fbd597bf29ec3d90b7b1ee4d182e8ab41675d1070be2f1954 0002-disable-werror.patch